Find the answer to your Linux question:
Results 1 to 2 of 2
Hello, I have setup a system consisting of the host on AMD Athlon64. On it several VMs are running. Either SuSE 11.4 or 12.1. When I try to compile any ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2011
    Posts
    2

    QEMU/KVM All projects abort with internal compiler error


    Hello,

    I have setup a system consisting of the host on AMD Athlon64. On it several VMs are running. Either SuSE 11.4 or 12.1.

    When I try to compile any source project (with gcc 4.5.1 or 4.6.2), lately bacula, the 'make' is sooner or later aborted by "internal compiler error". Sometimes I am lucky with tinkering with compiling options like setting -O2 to -O0. Currently I am running the gcc testsuite. It looks like all test fail.
    All projects I tried so far ran without error with the same options on the host.

    So I think it is connected with the fact that the compilation is done within a VM. But I don't know how to get an angle on this. Maybe the compiler does not know with processorshould be compiled for?

    I do not know what information to post to help you analyze the problem, so please ask.

    Thank you,

    Tobi

  2. #2
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,737
    Have you tried with a slightly older GCC toolchain, such as 4.4? Virtual machine code is often very persnickety with regard to compiler versions.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •