Find the answer to your Linux question:
Results 1 to 3 of 3
Hi all, Ubuntu server 1010 64bit running as VM on Orcle Virtualbox. I followed; DNS (bind9) Configuration HowTo DNS (bind9) Configuration HowTo to config bind9. It went through w/o problem. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,792

    Unable to start bind9


    Hi all,

    Ubuntu server 1010 64bit running as VM on Orcle Virtualbox.

    I followed;
    DNS (bind9) Configuration HowTo
    DNS (bind9) Configuration HowTo

    to config bind9. It went through w/o problem.

    On restarting bind9;
    # /etc/init.d/bind9 restart
    Code:
     * Stopping domain name service... bind9
       ...done.
     * Starting domain name service... bind9
       ...fail!
    $ tail /var/log/syslog
    Code:
    Jan 29 16:43:33 server1 named[2467]: /etc/bind/named.conf.local:9: unknown option 'zone'
    Jan 29 16:43:33 server1 named[2467]: /etc/bind/named.conf.local:14: unknown option 'zone'
    Jan 29 16:43:33 server1 named[2467]: /etc/bind/named.conf.default-zones:2: unknown option 'zone'
    Jan 29 16:43:33 server1 named[2467]: /etc/bind/named.conf.default-zones:10: unknown option 'zone'
    Jan 29 16:43:33 server1 named[2467]: /etc/bind/named.conf.default-zones:15: unknown option 'zone'
    Jan 29 16:43:33 server1 named[2467]: /etc/bind/named.conf.default-zones:20: unknown option 'zone'
    Jan 29 16:43:33 server1 named[2467]: /etc/bind/named.conf.default-zones:25: unknown option 'zone'
    Jan 29 16:43:33 server1 named[2467]: /etc/bind/named.conf:12: '}' expected near end of file
    Jan 29 16:43:33 server1 named[2467]: loading configuration: unexpected token
    Jan 29 16:43:33 server1 named[2467]: exiting (due to fatal error)
    $ cat /etc/bind/named.conf.local
    Code:
    //
    // Do any local configuration here
    //
    
    // Consider adding the 1918 zones here, if they are not used in your
    // organization
    //include "/etc/bind/zones.rfc1918";
    
    zone "server1.domain.com" {
            type master;
            file "/etc/bind/zones/server1.domain.com.db";
    };
    
    zone "0.168.192.in-addr.arpa" {
            type master;
            file "/etc/bind/zones/rev.0.168.192.in-addr.arpa";
    };
    Pls help. TIA

    B.R.
    satimis

  2. #2
    Linux Guru Lazydog's Avatar
    Join Date
    Jun 2004
    Location
    The Keystone State
    Posts
    2,677
    You have errors in the following files:

    named.conf
    named.conf.local
    named.conf.default-zones

    You could run named-checkconf and named-checkzone to check your files for errors. Read the MAN pages on how to use them.

    Regards
    Robert

    Linux
    The adventure of a life time.

    Linux User #296285
    Get Counted

  3. #3
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,792
    Quote Originally Posted by Lazydog View Post
    You have errors in the following files:

    named.conf
    named.conf.local
    named.conf.default-zones

    You could run named-checkconf and named-checkzone to check your files for errors. Read the MAN pages on how to use them.
    Hi Robert,

    On file /etc/bind/named.conf.options;

    After changing the line
    Code:
    allow-recursion { 127.0.0.1; 192.168.24.0/24;
    as;
    allow-recursion { 127.0.0.1; 192.168.24.0/24; };
    [/code]

    Now bind9 can be started. Thanks

    B.R.
    satimis

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •