Find the answer to your Linux question:
Results 1 to 2 of 2
I am trying to setup a bind server, I update the root.named file but in my resolv.conf file when I tell it to use 127.0.0.1 or my local ip address ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2012
    Posts
    5

    bind not working


    I am trying to setup a bind server, I update the root.named file but in my resolv.conf file when I tell it to use 127.0.0.1 or my local ip address and try to ping google it says unknown host.

    named.conf

    HTML Code:
    //
    // named.conf
    //
    // Provided by Red Hat bind package to configure the ISC BIND named(8) DNS
    // server as a caching only nameserver (as a localhost DNS resolver only).
    //
    // See /usr/share/doc/bind*/sample/ for example named configuration files.
    //
    
    options {
    listen-on port 53 { 127.0.0.1; };
    // listen-on-v6 port 53 { ::1; };
    directory "/var/named";
    dump-file "/var/named/data/cache_dump.db";
    statistics-file "/var/named/data/named_stats.txt";
    memstatistics-file "/var/named/data/named_mem_stats.txt";
    allow-query { localhost;10.105.21.0/24; };
    recursion yes;
    
    dnssec-enable yes;
    dnssec-validation yes;
    dnssec-lookaside auto;
    };
    //logging {
    //channel default_debug {
    //file "data/named.run";
    //severity dynamic;
    //};
    //};
    
    zone "." IN {
    type hint;
    file "named.root";
    };

  2. #2
    Just Joined!
    Join Date
    Dec 2009
    Location
    California
    Posts
    98
    What Operating System is this?
    Where is that named.conf
    After you run bind, is anything written to /var/log/messages?

    Assuming it's RedHat or CentOs, then you should check /etc/sysconfig/named and make sure you aren't trying to run chroot'd.

    Assuming you are not running chrooted, and further assuming that the file above is /etc/named.conf

    Does it work if you remove the dnssec stuff?

    When I try this on my server, it works without the dnssec. With the dnssec stuff, it throws a syntax error. That may be that my version of bind is older than yours.

    Are you running iptables? If so, try testing your config after shutting down iptables (/etc/init.d/iptables stop)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •