Find the answer to your Linux question:
Results 1 to 2 of 2
Hi all, I'm currently having an issue where mail is being rejected by my mail relay server; if I'm interpreting the issue correctly this is because Postfix insists on checking ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2012
    Posts
    14

    Disable MX lookups on Postfix?


    Hi all,

    I'm currently having an issue where mail is being rejected by my mail relay server; if I'm interpreting the issue correctly this is because Postfix insists on checking then does not recognise the sender's domain. Error message received:

    5.7.1 SMTP; 550 5.7.1 sender domain does not exist> #SMTP#

    What I would like is for Postfix not to check the domain; I have read around on the topic and have found ways to disable MX lookups by inserting square brackets around the destination address for relay settings within /etc/postfix/transport and /etc/postfix/master.cf; however, in this setup the server acts as a mail server to the internet and relaying is not configured using the relay statements within those files. I was wondering, does anyone know of another way to stop Postfix querying the domain, or indeed some other solution that might work in this instance?

    Thanks!

  2. #2
    Just Joined!
    Join Date
    Apr 2012
    Posts
    14
    Just FYI to everyone, I eventually resolved this by masquerading the domain. Because the normal method of doing this (e.g. inserting a 'masquerade_domains = domain.com' statement in main.cf) didn't work for me for reasons I have yet to figure out, I instead made the following changes:

    Code:
    ## append the following to /etc/postfix/main.cf
    smtp_generic_maps = hash:/etc/postfix/generic   
    
    ## insert the following into /etc/postfix/generic
    oracle@domain.to.mask.from oracle@domain.to.mask.to   ## append any users that need to send mail from server to generic file
    
    postmap /etc/postfix/generic     ## perform postmap
    service postfix restart          ## restart postfix
    And that worked - so I'm marking this thread as solved.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •