Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 12 of 12
Originally Posted by elija Tto check if apache is running on red hat based distros use the following command Code: ps aux | grep httpd and you should see some ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    May 2012
    Posts
    96

    Quote Originally Posted by elija View Post
    Tto check if apache is running on red hat based distros use the following command
    Code:
     ps aux | grep httpd
    and you should see some output.
    Replying from my CentOS box, i have some strange results

    Here is the result of the above command:
    Code:
    [root@server Silman]# ps aux | grep httpd
    root     24898  0.0  0.0 103232   816 pts/0    S+   22:25   0:00 grep httpd
    Quote Originally Posted by elija View Post
    If apache is not running use the command
    Code:
    service httpd start
    to kick it off. To make sure apache starts when you boot up use
    Code:
    chkconfig httpd on
    I did this just to be double safe and this is where the weird happens:

    Code:
    [root@server Silman]# service httpd start
    Starting httpd: Warning: DocumentRoot [/var/www/html/apps] does not exist
    Syntax error on line 21 of /etc/httpd/conf/sites-enabled/000-apps.vhost:
    Wrapper /var/www/html/php-fcgi-scripts/apps/.php-fcgi-starter cannot be accessed: (2)No such file or directory
                                                               [FAILED]
    Code:
    [root@server Silman]# chkconfig httpd on

    what does that error on the httpd start mean?

    Quote Originally Posted by elija View Post
    To change the port apache listens on will probably mean editing the /etc/httpd/conf/httpd.conf file and modifying the port in there. I can't remember how Centos does it so it may be in one of the files in /etc/httpd/conf.d and in both cases you will need to restart apache.
    interestingly enough, both conf and conf.d are both completely empty...that cant be right.

    Quote Originally Posted by elija View Post
    The perfect server guides are really recipies for what the author does, if you want understanding then there is a lot of extra reading coming your way with quite a lot of time spent trying things out and breaking them.
    i see, well i have all summer to learn and i really want to get this stuff down! Is there other guides I can follow for setting up a servers? Can you recommend any books/websites/etc that might help me on my quest to learn this stuff. My goal is to get a working webserver by mid-late july so i can explore more about server side scripting and AJAX.

    thanks so much!

  2. #12
    Just Joined!
    Join Date
    May 2012
    Posts
    96
    I dont know what happened but some miracle caused my port 80 to open up!!! Now i dont need to bother with redirecting it (also i tried to forward SSH and it opened up too)!!!!!!

    I am so excited! I currently have XAMPP for linux installed and i can connect to my server locally and even when someone outside the network tried to connect they were able to. The one problem is whenever I or anyone else connects this message pops up:

    Code:
    ?php if (!empty($_SERVER['HTTPS']) && ('on' == $_SERVER['HTTPS'])) { $uri = 'https://'; } else { $uri = 'http://'; } $uri .= $_SERVER['HTTP_HOST']; header('Location: '.$uri.'/xampp/'); exit; ?> Something is wrong with the XAMPP installation :-(
    what in the world is this? i am sooooo close to getting this thing running as a webserver i can taste it! I just need to learn how to get my websites on their (and possibly learn how to do it remotely so i can update my website by developing on my laptop and transfering the files).


    Can anyone help me get this thing running? I know i am soooo close, i can taste it!

    EDIT: I hear XAMPP is not good to use as an actual webserver. Is this true? Thats really disappointing because i have been having a lot of trouble getting the individual packages working.... There needs to be a better tutorial on how to install and configure these damn packages. I am almost considering switching to debian because it seems like it has more support for setting up a web server.

    Please! I really need help with this, i have no clue how to configure this thing!
    Last edited by Silman; 06-30-2012 at 06:39 AM.

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •