Find the answer to your Linux question:
Results 1 to 3 of 3
Hi Friends, I set up the sendmail in my perosnal home lab. I am using mutt to send the email in between the machines. Everything is working fine if i ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2010
    Posts
    14

    Sendmail saying "user unknown" after setting up MX


    Hi Friends,

    I set up the sendmail in my perosnal home lab. I am using mutt to send the email in between the machines. Everything is working fine if i send email like <username><hostname>. Now i set up the MX record for my domain "home.com" and then i was trying to send the email to like root<at t<>home.com, but in this case as soon as i press "Y" to send the email in mutt; i get this error
    Code:
    Error sending message, child exited 67 (User unknown.)
    Even in the sendmail logs it shows user known. I know that my sendmail was not configured to accept message from the domain home.com, so i added the home.com to /etc/mail/local-host-names file but still this error remains. It is weird and i assume i should get a delivery failure with something saying like "relaying rejected"

    So can anyone please help me figuring out what is going on here ?>

  2. #2
    Just Joined!
    Join Date
    Nov 2010
    Posts
    14

    Can somebody answer ???

    Can somebody answer to my post above

  3. #3
    Linux Newbie
    Join Date
    Jan 2012
    Location
    Ohio
    Posts
    175
    This may be something you have done already, but do you have a virtual user table set up? Check out this Wiki for more detail
    6 Ways to Configure Sendmail - wikiHow

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •