Find the answer to your Linux question:
Results 1 to 3 of 3
I am working on getting a web server working on my Debian computer, and am setting up Apache. When I try to restart Apache I get the error :~# /etc/init.d/apache2 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2011
    Posts
    11

    apache2Action 'start' failed.


    I am working on getting a web server working on my Debian computer, and am setting up Apache. When I try to restart Apache I get the error

    :~# /etc/init.d/apache2 restart
    Restarting web server: apache2Action 'start' failed.
    The Apache error log may have more information.
    failed!

    Then in the Apache error log (/var/log/apache2/error.log) the only new addition is

    "Unable to open logs"

    I've searched for a while to try to figure this out, but haven't found anything yet. Any ideas?

    Thanks,

  2. #2
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    make sure your apache config file is pointing to a location for logs (via the ErrorLog and CustomLog directives, I think) that is writable by the user running the webserver (or make sure that the dir even exists, especially if you've added VirtualHosts but those logs can't get written to b/c of perms/missing dirs).

    also, you could try calling the httpd binary manually, to try and get more verbose output.

  3. #3
    Just Joined!
    Join Date
    Sep 2011
    Posts
    11
    Okay, I feel like an idiot now. I went back and disabled all the url's from the virtualization, reading the config files one at a time. I found the one that was causing problems and after careful examination, comparing it to others, found the typo that I had made and missed the many times I looked through it again.

    Thanks for the help.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •