Find the answer to your Linux question:
Results 1 to 5 of 5
i Configured new domain but its pointing to some other ip in NS A record if i mention ip or domain name its giving error domain ns not found starting ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2012
    Posts
    6

    Angry Domain is Pointing to wrong ip


    i Configured new domain but its pointing to some other ip

    in NS A record if i mention ip or domain name its giving error domain ns not found starting failed

    <<>> DiG 9.7.0-P2-RedHat-9.7.0-10.P2.el5_8.1 <<>> indigitalplan.com
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 48210
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 0
    ;; QUESTION SECTION:
    ;indigitalplan.com. IN A
    ;; ANSWER SECTION:
    indigitalplan.com. 1795 IN A 119.252.148.27
    ;; AUTHORITY SECTION:
    indigitalplan.com. 1795 IN NS ns2.rediffmailpro.com.
    indigitalplan.com. 1795 IN NS ns.rediffmailpro.com.
    ;; Query time: 3 msec
    ;; SERVER: 203.187.255.90#53(203.187.255.90)
    ;; WHEN: Wed Jul 11 18:19:56 2012
    ;; MSG SIZE rcvd: 100
    hi i newly configured postfix and domain, SPF is showing neutral and DKIM signature is not showing
    if i dig my domain its pointing to wrong ip how to resolve this issue

  2. #2
    Linux User Krendoshazin's Avatar
    Join Date
    Feb 2005
    Location
    London, England
    Posts
    471
    You will need to edit to records on the server they are held on. Which name server is the authority for these records?

  3. #3
    Just Joined!
    Join Date
    Jul 2012
    Posts
    6

    in forward lookup zone i mention correctly

    This is what i configured forward lookup named.conf

    acl lan {
    123.201.xx.xx/30;
    127.0.0.1;
    };

    controls {
    inet 123.201.xx.xx allow {localhost;}keys {rndckey;};

    };

    logging {
    category default { default_syslog; };
    category lame-servers { null; };
    };

    options {
    pid-file "/var/run/named/named.pid";
    directory "/var/named/";
    dump-file "named_dump.db";
    forward only;
    forwarders {
    # the following IP addresses are my ISPs DNS Servers. These will be used for looking up
    # hostnames that I don't locally manage, i.e. the REST OF THE INTERNET!
    203.187.xx.xx; # my ISPs DNS Server #1
    203.187.xx.xx; # my ISPs DNS Server #2
    };
    /*
    * If there is a firewall between you and nameservers you want
    * to talk to, you might need to uncomment the query-source
    * directive below. Previous versions of BIND always asked
    * questions using port 53, but BIND 8.1 uses an unprivileged
    * port by default.
    */
    query-source address * port 53;
    # allow-query { lan; };
    # allow-recursion { lan; };
    # allow-transfer { lan; };
    #directory "/var/named/";
    allow-query {localhost; 123.201.xx.xx; };
    allow-transfer {localhost; 123.201.xx.xx; };
    recursion yes;
    };


    zone "example.com" IN {
    type master;
    file "emample.com";
    allow-update { none; };
    };


    For lookup zone


    $ORIGIN com.
    $TTL 3600 ; 1 hour
    iexample IN SOA ns.example.com. root.example.com. (
    2006051501 ; Serial
    10800 ; Refresh
    3600 ; Retry
    604800 ; Expire
    86400 ; Minimum TTL
    )

    ; DNS Servers
    IN NS ns1.example.com.
    ; IN NS ns2.example.com.

    ; MX Records
    IN MX 10 mail.example.com.
    IN MX 20 mx.example.com.

    ; Machine Names
    $ORIGIN example.com.
    example.com. IN A 123.201.xx.xx
    ;www IN CNAME example.com.
    ;ftp IN CNAME example.com.
    mail IN A 123.201.xx.xx
    @ IN A 123.201.xx.xx
    www IN A 123.201.xx.xx

    ;SPF Records
    @ IN TXT "v=spf1 ip4:123.201.xx.xx a mx ~all"
    mail IN TXT "v=spf1 a -all"

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Newbie
    Join Date
    Jun 2012
    Location
    SF Bay area
    Posts
    195
    Code:
    $ dig indigitalplan.com
    
    ; <<>> DiG 9.2.0 <<>> indigitalplan.com
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 39658
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 2
    
    ;; QUESTION SECTION:
    ;indigitalplan.com.             IN      A
    
    ;; ANSWER SECTION:
    indigitalplan.com.      1800    IN      A       123.201.55.30
    
    ;; AUTHORITY SECTION:
    indigitalplan.com.      1800    IN      NS      ns.rediffmailpro.com.
    indigitalplan.com.      1800    IN      NS      ns2.rediffmailpro.com.
    
    ;; ADDITIONAL SECTION:
    ns.rediffmailpro.com.   172797  IN      A       202.54.124.166
    ns2.rediffmailpro.com.  172797  IN      A       203.199.83.166
    
    ;; Query time: 3501 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Thu Jul 12 02:20:16 2012
    Since I got a 123.201.55.30 when I tried just now, I'm assuming you fixed it? At least that's different from the 119.252.148.27 address you said was the wrong one in your original posting.

  6. #5
    Just Joined!
    Join Date
    Jul 2012
    Posts
    6
    thank its solved...i am facing one more issue in postfix mail server smtp error getting

    This is error getting while sending mail from php mailer
    SMTP Error: The following recipients failed: info@gmail.com
    message not sent
    Mailer Error: SMTP Error: The following recipients failed: info@gmail.com<p>SMTP server error: 5.7.1 <example.com[123.201.xx.xx]>: Client host rejected: Access denied
    Var/maillog
    NOQUEUE: reject: RCPT from example.com[123.201.xx.xx]: 554 5.7.1 <example.com[123.201.xx.xx]>: C lient host rejected: Access denied; from=<root@example.com> to=<info@ gmail.com> proto=ESMTP helo=<mail.example.com>

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •