Find the answer to your Linux question:
Results 1 to 4 of 4
Hi, I hope this is the correct forum for this Q. My users have mail in their mailboxes -- I can sit at the terminal and look at their mail ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2003
    Location
    Elmore Co., AL USA
    Posts
    10

    can't retrieve mail from localhost


    Hi,

    I hope this is the correct forum for this Q.

    My users have mail in their mailboxes -- I can sit at the terminal and look at their mail and see it using Pine, for example. But, I can't get a Windoze MUA (such as Eudora or Outlook Express) to retrieve it.

    I have searched first (over and over), I'm totally befuddled, and I hope someone here can help.

    I'm running SuSE 8 (2.4.18-4GB) on an i586 which is connected to a LAN via eth1 (192.168.40.0/24) and to the outside world via eth0 ==> ADSL (static IP)

    I am using iptables with a script that I developed with lots of help and it works wonderfully. Although part of my problem could be that I am not handling pop3 properly on the local side (eth1).

    I am using Exim-4.10 which has been very little trouble to compile and set up. Each user has a mailbox on the host (192.168.40.1) and I can sit at the terminal and use su to "become" each user in turn. From the terminal, using Pine, I can do all the things a mail user would like to do:

    create & send mail to other users on the system
    create & send mail to other users in the world
    receive mail from other users on the system, and
    receive mail from other users in the world.

    Therefore, I KNOW that my IP is routable, my domain dns points to my IP, and my Westel router/modem is passing mail IN and OUT.

    The only problem I am having is that I have to do this at the terminal (or via ssh from a remote terminal).

    My users are very particular about sitting at their OWN DESKS!! (Imagine that!!) -- "picky, picky, picky" is what *I* say!

    That would be OK, but they all speak MS-Windoze. So, I decided to equip each of them with Eudora 5.2 for Windoze (I rejected Outlook & Outlook Express because I'm convinced (paranoid) that O & OE are "neon" targets for miscreants and virus engineers.)

    Once upon a time, when I had this same system on ADSL with a different provider, all of this worked. I could use Eudora to send and retrieve mail from a Windoze desktop.

    I really don't know what happened. I *have* performed online updates of my SuSE O/S, and that may be where the problem is. Or, as I said before, my iptables with respect to pop3 on the private network side may be not correct.

    I'm in over my head, and I could use some advice.

    Exim is doing its job.
    Mail is passing through the router/modem to the outside world.
    Mail is passing between local mailboxes on the local Linux host.
    Every user has a uid/pw on the Linux host ("Steve")
    I can ssh to "Steve" from any machine on the private network.
    I can ssh to "Steve" from my home (also static IP which my iptables explicity accepts for ssh).
    I do not run telnet.

    I have tried OE just to see if it would work (to see if it was a Eudora problem, but Eudora DID work before, so that's not likely). OE didn't work either.

    I'm crying here -- and the tears don't look good on my gray stubble. (Plus, I have enough wrinkles already!)

    ?????

    TIA
    Chuck Moore

  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Are you trying to make them access their mail via POP or IMAP? What daemon are you using, and are you sure that your iptables script isn't blocking the relevant port? If you're using an xinetd service, have you enabled it? See so that there's something listening with this:
    Code:
    netstat -antp | egrep '(110|143)'

  3. #3
    Just Joined!
    Join Date
    Jun 2003
    Location
    Elmore Co., AL USA
    Posts
    10

    Thanks for taking time to respond!

    I am not sure about a few things (which, my wife would tell you, is VERY uncharacteristic! )

    But, I tried the netstat as you suggested. Here's the response:

    tcp 0 0 :::110 :::* LISTEN 4468/xinetd

    Now, as to POP v. IMAP, I don't know. I did apparently have ipop3d installed. However, I have decided to replace it with qpopper -- for two reasons:

    1) one thing doesn't work, try something else, and

    2) qpopper is a Qualcomm "product" as is Eudora -- maybe they'll like each other.

    As to iptables, I just don't know. I DO know that

    theworld <====> Steve (via eth0) are talking -- mail goes out and mail comes in.

    Steve <= => 192.168.40.xxx (via eth1) may be messed up.

    I am very confused about what is port 25 and what is port 110 (usage).

    what I have is this:

    iptables -t filter -A INPUT -i eth1 -p tcp -s 192.168.40.0/24 -d 192.168.40.1 --dport 25 -j ACCEPT

    iptables -t filter -A INPUT -i eth1 -p tcp -s 192.168.40.0/24 -d 192.168.40.1 --dport 110 -j ACCEPT

    iptables -t filter -A OUTPUT -o eth1 -p tcp -s 192.168.40.1 -d 192.168.40.0/24 --dport 25 -j ACCEPT

    iptables -t filter -A OUTPUT -o eth1 -p tcp -s 192.168.40.1 -d 192.168.40.0/24 --dport 110 -j ACCEPT

    If you have other suggestions, I'd welcome them.

    Oh, as to what I WANT!

    I want my users, all of whom are running some form of Win9x or WinXP, to be able to retrieve mail from their respective mailboxes on Steve using a Windows-based MUA such as Eudora (my current preference).

    Steve is 192.168.40.1 and he talks to them via eth1

    Each user is assigned an IP in the 192.168.40.0/24 and I can ssh from any station to 192.168.40.1 and log in as user and read and write mail.

    However, PUTTY is beyond what my users are generally capable, and it lacks some elegance.

    Thanks again.

    Chuck

  4. #4
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    OK, so the POP3 service is listening and the firewall isn't blocking it. Try telnetting to it and log in as a user manually. Telnet to it from Steve with "telnet 127.0.0.1 110", and, after you get the first +OK response from the server, issue these commands:
    Code:
    USER username
    PASS pw
    Of course, replace "username" and "pw" with whatever you actually want to use. The server should reply with an additional +OK after every command. If it's unsuccessful, check your logs for any clues.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •