Find the answer to your Linux question:
Results 1 to 4 of 4
Hi! I have upgraded Debian Woody to Sarge. I also tried installing mysql and php4 with support for mysql. Starting the Apache web server creates this error in the log. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2004
    Posts
    4

    PHP, MySQL on Debian Sarge


    Hi!

    I have upgraded Debian Woody to Sarge. I also tried installing mysql and php4 with support for mysql. Starting the Apache web server creates this error in the log.

    Code:
    PHP Warning:  Unknown(): Unable to load dynamic library '/usr/lib/perl5/auto/DBD/mysql/mysql.so' - /usr/lib/perl5/auto/DBD/mysql/mysql.so: undefined symbol: PL_memory_wrap in Unknown on line 0
    Tried to do a search on PL_memory_wrap, but I did not find much. Apparently I cannot load the mysql extension. PHP finds the file mysql.so but doesn't seem to be able to read it.

    Can anybody give me some hints about whats is wrong here?

    Espen

  2. #2
    Linux Newbie
    Join Date
    Dec 2004
    Location
    Barrie, Ontario
    Posts
    219
    For some reason, PHP is trying to use a mysql.so that has been compiled for PERL. Naturally, PERL's API and PHP's API differ, so this would fail. When you compiled PHP, you pointed it at the wrong MySQL lib. There is an option compile PHP with the builtin MySQL library. Try that.
    Blog - KB5UMQ - Linux User #272983
    3 Rules:
    1) "It doesn't work..." is simply not useful information.
    2) Don't cross post!
    3) If you are asking for help, start by telling us your distro/os and version.

  3. #3
    Just Joined!
    Join Date
    Oct 2004
    Posts
    4
    Ok, thanks for the information. However, I have only used the regular php package from Debian together with apt-get to install it. That is what I did with mysql and php-mysql as well. I have not compiled any of these packages myself.

    I have tried to uninstall all the packages and reinstall them again, but this does not fix the problem. How can I get it to use the PHP version of mysql.so and not the Perl version?

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Oct 2004
    Posts
    4
    As many times before I have no idea how it got fixed but after a general update on my server, my problem is now gone.

    Thanks for you help!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •