Find the answer to your Linux question:
Results 1 to 3 of 3
I am not sure why I am getting all httpd logs under /var/log/messages. I have make sure the following changes under /etc/httpd/conf/httpd.conf and restarted "service httpd restart" CustomLog "|/usr/sbin/rotatelogs /var/log/httpd/access_log.%Y-%m-%d ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2012
    Posts
    3

    why httpd logs are generating under /var/log/messages


    I am not sure why I am getting all httpd logs under /var/log/messages. I have make sure the following changes under /etc/httpd/conf/httpd.conf and restarted "service httpd restart"


    CustomLog "|/usr/sbin/rotatelogs /var/log/httpd/access_log.%Y-%m-%d 86400" combined
    CustomLog |/usr/local/bin/apache_syslog combined


    Please help!

  2. #2
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,846
    Are you running any virtual hosts? They may (it's probably quite common) to specify different log files for each virtual host. This would override any global setting you put in for all websites.
    Linux user #126863 - see http://linuxcounter.net/

  3. #3
    Just Joined!
    Join Date
    Aug 2012
    Posts
    3
    Thanks, Roxoff.

    I check the virtual host configuration as well.

    if I turn off the syslog server then I don't get any message. I do have another system which has exact configuration and it doesn't log the message under /var/log/messages.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •