Find the answer to your Linux question:
Results 1 to 10 of 10
Hello everyone, (Newbie Linux...) Ive just setup a new RHEL6 server and trying to shares folders to windows xp and windows 7 pcs in a Windows 8008 domain. When win ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2012
    Posts
    5

    Samba sharing for windows RHEL 6 - Error 0x80070035 The network path .


    Hello everyone, (Newbie Linux...)
    Ive just setup a new RHEL6 server and trying to shares folders to windows xp and windows 7 pcs in a Windows 8008 domain.

    When win pc access the share i get this:
    "Error 0x80070035 The network path was not found.

    RHEL server06 is not a member of the win domain and I just want alle users/guest users ALL users to have access to shares.

    Can anyone help me out ?

    Samba config:
    [global]
    dns proxy = no
    log file = /var/log/samba/log.%m
    netbios name = SERVER06
    cups options = raw
    load printers = yes
    server string = SERVER06
    idmap gid = 16777216-33554431
    socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
    workgroup = LCGLAD.LOCAL
    os level = 20
    security = share
    winbind use default domain = no
    max log size = 50
    template shell = /bin/false

    Shares:

    [meragui]
    writeable = yes
    printable = no
    guest only = yes
    public = yes
    path = /home/mera/meragui

  2. #2
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    is it the Win7 pc only that you have the error on, or the XP one, too?

  3. #3
    Just Joined!
    Join Date
    Aug 2012
    Posts
    5
    Quote Originally Posted by atreyu View Post
    is it the Win7 pc only that you have the error on, or the XP one, too?
    Thank you for replying
    Yes same problem with xp and server 2003, 2008

    Thx

  4. $spacer_open
    $spacer_close
  5. #4
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    Quote Originally Posted by larsjuhl View Post

    [meragui]
    writeable = yes
    printable = no
    guest only = yes
    public = yes
    path = /home/mera/meragui
    Add a line containing:

    Code:
    valid users = <username>
    i assume the username you'd use is "mera". Then add that username to the samba db, e.g.:

    Code:
    smbpasswd -a mera
    then, from windows, use that username and password to connect.

  6. #5
    Just Joined!
    Join Date
    Aug 2012
    Posts
    5
    ok thank you Ive made the changes
    smbpasswd -a mera

    If I connect from a pc I still get same error and I do not get at prompt to logon using a username or password.
    If I use a pc not in the domain Iam asked for password but entering the credentials gives same problem.

    I would like to give everyone full access to the shares and no one to be asked for a password..
    thank you again

  7. #6
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    Quote Originally Posted by larsjuhl View Post
    I would like to give everyone full access to the shares and no one to be asked for a password..
    ah, i missed that part. try editing your smb.conf file according to this guide:

    http://www.debuntu.org/guest-file-sharing-with-samba

    (the guide is for Debian, but the smb.conf file is distro-agnostic)

    make sure to restart samba after making the changes.

  8. #7
    Just Joined!
    Join Date
    Aug 2012
    Posts
    5

    Unhappy

    thank you atreyu
    Ive done what it says in the ubuntu link.
    added "guest account = nobody"
    now global looks like this
    [global]
    dns proxy = no
    log file = /var/log/samba/log.%m
    netbios name = SERVER06
    cups options = raw
    load printers = yes
    server string = SERVER06
    idmap gid = 16777216-33554431
    socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
    workgroup = windows domain
    os level = 20
    security = share
    guest account = nobody
    winbind use default domain = no
    max log size = 50
    template shell = /bin/false

    created a new share:


    [meragui]
    path = /home/mera/meragui
    browseable = yes
    read only = yes
    guest ok = yes

    still same result I can see the shares p access gives network error as before...

    thank you for helping!
    Lars

  9. #8
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    is SELinux enabled?
    Code:
    getenforce
    is a firewall/iptables running? if so, temporarily stop it:
    Code:
    service iptables stop
    i assume you can ping the samba box, does nmap say the ports are open?

    Code:
    nmap -n <IP_ADDRESS>
    also, try changing the path to the share in [meragui] to something else, and make sure it is readable by all, e.g.:

    Code:
    mkdir /tmp/myshare
    chmod 0777 /tmp/myshare
    then in smb.conf:
    Code:
    [meragui]
    path = /tmp/myshare

  10. #9
    Just Joined!
    Join Date
    Aug 2012
    Posts
    5
    thank you

    getenforce gave reply "Enforcing"
    Ive stopped iptables and created the /tmp/myshare folder with chmod 0777
    changed the [meragui] to that "myshare" same error.
    then removed so the smb.conf had
    [meragui]
    path = /tmp/myshare

    Now from windows I get "meragui" not accessible you might not have permission.... which is ok since we removed guetst

  11. #10
    Trusted Penguin
    Join Date
    May 2011
    Posts
    4,353
    Quote Originally Posted by larsjuhl View Post
    getenforce gave reply "Enforcing"
    that may be your problem. temporarily stop SELinux with this command (as root):
    Code:
    setenforce 0
    and then test.

    changed the [meragui] to that "myshare" same error.
    then removed so the smb.conf had
    [meragui]
    path = /tmp/myshare

    Now from windows I get "meragui" not accessible you might not have permission.... which is ok since we removed guetst
    this is all confusing to me. if i were you, i'd either:

    a) create a share with access granted to a specific user, as in my original example. once you get that working, then worry about guest-accessible shares.

    b) create a guest-accessible share, as detailed in the Debian link.
    Last edited by atreyu; 09-06-2012 at 10:04 PM. Reason: link is for Debian, not Ubuntu

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •