Find the answer to your Linux question:
Results 1 to 4 of 4
Hi everyone I have an old server running docuwiki. There was a powercut a few days ago and since then I can not start HTTPD on the server and therefore ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux User
    Join Date
    Jul 2007
    Location
    Kronos
    Posts
    286

    Can not start HTTPD


    Hi everyone

    I have an old server running docuwiki.
    There was a powercut a few days ago and since then I can not start HTTPD on the server and therefore I can not view my docuwiki pages.

    The error I get is:

    Starting httpd: Syntax error on line 112 of /etc/httpd/conf.d/ssl.conf:
    SSLCertificateFile: file '/etc/pki/tls/certs/localhost.crt' does not exist or is empty
    [FAILED]


    I googled the error but nothing of the suggested solutions helped me or I propably applied them wrong.

    I looked for localhosts.crt and indeed is not inside /etc/pki/tls/certs/localhost.crt. I copied the same file from another server but when I attempted to restart HTTPD, it failed again but without mentioning anything about SSL Certificates. As you can understand I don't really know what I am doing and why this localhost.crt file disappeared.

    Finally I decided to follow someone's suggestion on another forum by creating a new certificate following the instructions here but with no luck:

    SSL/TLS Strong Encryption: FAQ - Apache HTTP Server

    Can someone please help me? If there is anything else you could suggest to me doing that would be great.

    Many thanks.
    One Love!!!

  2. #2
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,914
    Do you need to access this through ssl? Do you have a http rather than an https address to connect to the server? If so, you can temporarily turn off your ssl configuration by renaming (using the 'mv' command) the ssl.conf to something like ssl.conf.disabled, then starting your httpd service. This should then get you access to the server to edit your wiki pages.

    Before you can use your ssl variant of the web site you'd need to create a new public/private key pair, then wrap the public key in a certificate. In the ssl.conf file there are lines that specify both the certificate and its matching private key. The server needs both to function - you probably just need to carefully step through the guide again and re-create them, then ensure you've put them into your ssl.conf file correctly.
    Linux user #126863 - see http://linuxcounter.net/

  3. #3
    Linux Guru Rubberman's Avatar
    Join Date
    Apr 2009
    Location
    I can be found either 40 miles west of Chicago, in Chicago, or in a galaxy far, far away.
    Posts
    11,695
    When the system failed, you lost some data. Has the system run fsck on the file systems to repair them? In any case, you will need to restore the SSL certificate file. Unless it is a self-signed certificate, you will need to contact the CA (Certificate Authority) that issued it for a replacement.
    Sometimes, real fast is almost as good as real time.
    Just remember, Semper Gumbi - always be flexible!

  4. $spacer_open
    $spacer_close
  5. #4
    Linux User
    Join Date
    Jul 2007
    Location
    Kronos
    Posts
    286
    Thank you both for your replies.

    I use http to connect to it. Renaming ssl.conf fixed the problem. My wikipages are back.

    Thanks a lot Roxoff
    One Love!!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •