Find the answer to your Linux question:
Results 1 to 2 of 2
Last night I ran a new backup scripts that did a mysql dump of all data. Today the server was running fine, and then started to loose connection to certain ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2012
    Posts
    2

    Mysql fails to start - mysqld service is running...


    Last night I ran a new backup scripts that did a mysql dump of all data. Today the server was running fine, and then started to loose connection to certain tables. When I tried
    Code:
    service mysqld restart
    it gave me an error:
    Code:

    "chown: cannot access `/var/lib/mysql\r': No such file or directory"
    . With that \r it looked as if a file was in the wrong format.

    I opened the the /etc/my.cnf and set the format to unix with:
    Code:

    Code:
    set fileformat=unix
    and saved it.

    Now restarting the mysqld gives me:
    Code:

    Timeout error occurred trying to start MySQL Daemon.
    The /etc/my.cnf file error log is pointing to /var/log/mysqld.log but that is blank.

    Would removing mysql and reinstalling it help? I'm keeping that as a last resort if it's just a file or setting problem. The script I ran just used a simple
    Code:

    Code:
    mysqldump --user=myuser --password=mypass--all-databases --add-drop-table > /media/usbdisk/WebBackups/tmp_backup/backup.sql
    When I do status check on mysqld it says it's running... but fails to start.

    I've set the permission of my.cnf to 644 owned by root.

    I think a key to this is getting the error logs, but they don't seem to be writing. Any ideas why?


    Thanks for any help.
    Last edited by wad3brown; 10-16-2012 at 10:40 PM. Reason: more detail

  2. #2
    Just Joined!
    Join Date
    Oct 2012
    Posts
    2
    I found a suggestion to check if there was anything that could be deleted out of the /var folder. I opened up about 500mb and mysql was able to connect. Not sure why those are associated, but it worked.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •