Find the answer to your Linux question:
Results 1 to 6 of 6
I have a file server with Ubuntu 12.04 and samba server. smb.conf: #======================= Global Settings ===================================== [global] workgroup = WORKGROUP server string = Samba Server %v netbios name = fileserver ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2012
    Posts
    3

    Samba share problem


    I have a file server with Ubuntu 12.04 and samba server.

    smb.conf:
    #======================= Global Settings =====================================
    [global]
    workgroup = WORKGROUP
    server string = Samba Server %v
    netbios name = fileserver
    security = user
    map to guest = bad user
    dns proxy = no
    #============================ Share Definitions ==============================
    [home]
    path = /home
    browsable =yes
    writable = yes
    guest ok = yes
    read only = no

    [1000GB]
    path = /media
    browsable =yes
    writable = yes
    guest ok = yes
    read only = no

    I connect windows 7 to my samba shares, ask me for login and everything OK. (allow read,write).

    If i connect to my shares with Linux mint or windows XP, not asking me for login and i see my shares without write permissions.

    1) Why not asking me for login for windows xp and other linux clients?

    2) How can i have write access from windows xp and linux clients?

    Thank you

  2. #2
    Just Joined!
    Join Date
    Jan 2006
    Posts
    1
    Hi
    as i remember i think you need to be in the same workgroup as your ubuntu and the you need to enable file and printsharing on your winXP

    I hope it helps

  3. #3
    Just Joined!
    Join Date
    Jun 2012
    Posts
    1

    Cool

    Hi,

    Its due to the Workgroup name, i believe that the same workgroup name was in the Windows xp with the same username as you are using for Samba user.

    Regards,
    Sukumar K.L.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Oct 2012
    Posts
    3
    Thank you for your answers

    windows 7 & xp machines are in WORKGROUP.

    Permissions for my shares are 755, when i change to 777, can write from xp and linux machines but still not asking for login.

  6. #5
    Just Joined!
    Join Date
    Nov 2004
    Posts
    4
    Chances are, you have two different userid on the Window 7 and the XP boxes. Samba is authenticates at the userid level. If you have two different ids, they you can change the samba user setting to always authenticate using a single ID for both of them. You will need to add the id translation to the samba config area.

    As for the linux box, are you sure you are using smb on the mount command (whether in fstab or manual)? Check the fstab file on the linux box to see if it has either of UID and GID specified on the mount command. Be sure they are the ones that match those found for on samba server when opening the directory.

    You may have samba to allow all machines in a specific group to have read access as well as the directory allow for world access for read set for that share. Therefore, it will not ask for login and such from the linux boxl.

  7. #6
    Just Joined!
    Join Date
    Oct 2012
    Posts
    3
    I solved the problem..

    guest ok = yes
    change to no

    Thank you

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •