Find the answer to your Linux question:
Results 1 to 2 of 2
I'm having problems setting up vsftpd. I can connect all the way to dir listing but than it errors out with the info below. I tried so many different options ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2004
    Posts
    26

    vsftpd setup


    I'm having problems setting up vsftpd. I can connect all the way to dir listing but than it errors out with the info below. I tried so many different options and settings that I'm totally confused at this point.

    ~ Connecting...
    ~ Connected to xx.xx.xx.xxx, waiting for response...
    < 220 Welcome to Groundhogs FTP service.
    > USER mydir
    < 331 Please specify the password.
    > PASS *****
    < 230 Login successful.
    > REST 1
    < 350 Restart position accepted (1).
    > REST 0
    < 350 Restart position accepted (0).
    > SYST
    < 215 UNIX Type: L8
    > PWD
    < 257 "/home/mydir"
    ~ Login completed.
    > PASV
    < 227 Entering Passive Mode (192,168,1,2,161,236)
    > TYPE A
    < 200 Switching to ASCII mode.
    > LIST
    ! Socket Error: no connection
    ~ Could not retrieve directory listing for "/home/mydir/"
    ~ Disconnected

  2. #2
    Just Joined!
    Join Date
    Dec 2004
    Posts
    26

    Here is my vsftpd.conf file

    anonymous_enable=NO
    local_enable=YES
    write_enable=YES
    local_umask=022
    xferlog_enable=YES
    connect_from_port_20=YES
    xferlog_file=/var/log/vsftpd.log
    xferlog_std_format=YES
    ftpd_banner=Welcome to Groundhogs FTP service.

    #chroot_list_enable=YES
    #(default follows)
    #chroot_list_file=/etc/vsftpd.chroot_list
    #chroot_local_user=YES

    ls_recurse_enable=YES

    pasv_enable=YES
    pam_service_name=vsftpd
    #userlist_deny=NO
    #userlist_enable=YES
    #userlist_file=/etc/vsftpd.user_list
    #enable for standalone mode
    listen=YES
    tcp_wrappers=YES

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •