Hi,
I have configured pptp vpn server in my centOS 5.5 machine,

i have installed vpn server as foolows
#yum install ppp

#vim /etc/pptpd.conf
localip 192.168.10.53 (VPN Server IP)
remoteip 192.168.10.200-300

#vim /etc/ppp/options.pptpd
ms-dns 123.x.x.x (my isp dns ip's)
ms-dns 123.x.x.x

#vim /etc/ppp/chap-secrets
username pptpd passwd *

#vim /etc/sysctl.conf
net.ipv4.ip_forward = 1

#sysctl -p

#iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE
#iptables -A INPUT -i eth0 -p tcp --dport 1723 -j ACCEPT
#iptables -A INPUT -i eth0 -p gre -j ACCEPT

#service iptables save
#service iptables restart
#service pptpd start

Configured port forwading for VPN in router to 1723.

Then went to another windows xp computer which is not in this network,
created VPN network connection,

Then i can able to connect to vpn server,
I am getting
IP - 192.168.10.200
SUBNET MASK - 255.255.255.255
GATEWAY - 192.168.10.200

then i can ping the local network and i can access internet also,
when i am try to access shared folder of network or browsing network IP's, then the vpn connection automatically disconnecting.

here is the log message of pptp server...

Nov 15 15:33:53 admin pptpd[12328]: CTRL: Client 121.243.138.164 control connection started
Nov 15 15:33:53 admin pptpd[12328]: CTRL: Starting call (launching pppd, opening GRE)
Nov 15 15:33:53 admin pppd[12329]: Plugin /usr/lib/pptpd/pptpd-logwtmp.so loaded.
Nov 15 15:33:53 admin pppd[12329]: pppd 2.4.4 started by root, uid 0
Nov 15 15:33:53 admin pppd[12329]: Using interface ppp0
Nov 15 15:33:53 admin pppd[12329]: Connect: ppp0 <--> /dev/pts/2
Nov 15 15:33:56 admin pptpd[12328]: CTRL: Ignored a SET LINK INFO packet with real ACCMs!
Nov 15 15:33:56 admin pppd[12329]: MPPE 128-bit stateless compression enabled
Nov 15 15:33:58 admin pppd[12329]: found interface eth0 for proxy arp
Nov 15 15:33:58 admin pppd[12329]: local IP address 192.168.10.53
Nov 15 15:33:58 admin pppd[12329]: remote IP address 192.168.10.200
Nov 15 15:34:07 admin pptpd[12328]: GRE: read(fd=7,buffer=80515e0,len=8260) from network failed: status = -1 error = Message too long
Nov 15 15:34:07 admin pptpd[12328]: CTRL: GRE read or PTY write failed (gre,pty)=(7,6)
Nov 15 15:34:07 admin pppd[12329]: Modem hangup
Nov 15 15:34:07 admin pppd[12329]: Connect time 0.2 minutes.
Nov 15 15:34:07 admin pppd[12329]: Sent 12288 bytes, received 3443 bytes.
Nov 15 15:34:07 admin pppd[12329]: MPPE disabled
Nov 15 15:34:07 admin pppd[12329]: Connection terminated.
Nov 15 15:34:07 admin pppd[12329]: Exit.
Nov 15 15:34:07 admin pptpd[12328]: CTRL: Client 121.243.138.164 control connection finished


please help to solve the problem, looked into lot of forums still no luck.

thanks
suresh.