Find the answer to your Linux question:
Results 1 to 5 of 5
Hi all OS - Ubuntu 12.04 desktop 64bit running as VM Virtualizer Oracle VirtualBox airtime 2.2.1-1 phpmyadmin NOT installed. $ sudo service apache2 start Code: * Starting web server apache2 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,790

    Unable to start apache2


    Hi all

    OS - Ubuntu 12.04 desktop 64bit running as VM
    Virtualizer Oracle VirtualBox
    airtime 2.2.1-1

    phpmyadmin NOT installed.

    $ sudo service apache2 start
    Code:
     * Starting web server apache2
    Syntax error on line 5 of /etc/apache2/sites-enabled/airtime-vhost:
    ServerAdmin takes one argument, The email address of the server administrator
    Action 'start' failed.
    The Apache error log may have more information.
       ...fail!
    $ tail /var/log/apache2/error.log
    Code:
    [Wed Jan 16 15:26:06 2013] [notice] Apache/2.2.22 (Ubuntu) configured -- resuming normal operations
    [Wed Jan 16 15:26:07 2013] [notice] caught SIGTERM, shutting down
    [Wed Jan 16 15:26:08 2013] [notice] Apache/2.2.22 (Ubuntu) PHP/5.3.10-1ubuntu3.4 with Suhosin-Patch configured -- resuming normal operations
    [Wed Jan 16 15:34:43 2013] [notice] caught SIGTERM, shutting down
    Please advise where to check and how to fix the problem? TIA

    B.R.
    satimis

  2. #2
    Trusted Penguin Irithori's Avatar
    Join Date
    May 2009
    Location
    Munich
    Posts
    3,382
    The error explains where to look
    Code:
    Syntax error on line 5 of /etc/apache2/sites-enabled/airtime-vhost:
    ServerAdmin takes one argument, The email address of the server administrator
    You must always face the curtain with a bow.

  3. #3
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,790
    Quote Originally Posted by Irithori View Post
    The error explains where to look
    Code:
    Syntax error on line 5 of /etc/apache2/sites-enabled/airtime-vhost:
    ServerAdmin takes one argument, The email address of the server administrator

    $ cat /etc/apache2/sites-enabled/airtime-vhost
    Code:
    <VirtualHost *:80>
          ServerName icecast.mydomain.com
          #ServerAlias Example Domain
    
          ServerAdmin root@localhost An email address is required for the virtual host configuration.     
    
          DocumentRoot /usr/share/airtime/public
          DirectoryIndex index.php
    
          SetEnv APPLICATION_ENV "production"
    
          <Directory /usr/share/airtime/public>
                  Options -Indexes FollowSymLinks MultiViews
                  AllowOverride All
                  Order allow,deny
                  Allow from all
          </Directory>
    </VirtualHost>
    line 5 - original
    Code:
    ServerAdmin root@localhost An email address is required for the virtual host configuration.
    Tried;
    1)
    satimis@icecast.mydomain.com
    2)
    satimis@mydomain.com

    Also tried;
    ServerName www.mydomain.com

    satimis@mydomain.com (mail address)

    All failed.

    Apache2 was automatically installed when running;
    Code:
    $ sudo apt-get install airtime
    I suspect there is another config file its content must be matched.

    Must "hostname" be matched?

    $ hostname
    Code:
    ub1204dk02
    $ hostname -f
    Code:
    ub1204dk02
    Thanks

    satimis

  4. #4
    Trusted Penguin Irithori's Avatar
    Join Date
    May 2009
    Location
    Munich
    Posts
    3,382
    Probably the comment sign is missing, so all the words are evaluated. Which then leads to the error.
    But you dont need that comment anyways.

    Replace the ServerAdmin line by just this:
    Code:
    ServerAdmin satimis@mydomain.com
    You must always face the curtain with a bow.

  5. #5
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,790
    Quote Originally Posted by Irithori View Post
    Probably the comment sign is missing, so all the words are evaluated. Which then leads to the error.
    But you dont need that comment anyways.

    Replace the ServerAdmin line by just this:
    Code:
    ServerAdmin satimis@mydomain.com
    deleted the sentence "An email address is required for the virtual host configuration" after "ServerAdmin satimis@mydomain.com"

    $ cat /etc/apache2/sites-enabled/airtime-vhost
    Code:
    <VirtualHost *:80>
          ServerName icecast.mydomain.com
          #ServerAlias www.example.com
    
          ServerAdmin satimis@mydomain.com 
    
          DocumentRoot /usr/share/airtime/public
          DirectoryIndex index.php
    
          SetEnv APPLICATION_ENV "production"
    
          <Directory /usr/share/airtime/public>
                  Options -Indexes FollowSymLinks MultiViews
                  AllowOverride All
                  Order allow,deny
                  Allow from all
          </Directory>
    </VirtualHost>
    $ ls -al /etc/apache2/sites-enabled/
    Code:
    total 8
    drwxr-xr-x 2 root root 4096 Jan 16 22:05 .
    drwxr-xr-x 7 root root 4096 Jan 16 15:26 ..
    lrwxrwxrwx 1 root root   32 Jan 16 15:26 airtime-vhost -> ../sites-available/airtime-vhost
    Why this is a symbolic link?

    $ sudo service apache2 start
    Code:
     * Starting web server apache2
    apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName
       ...done.
    $ sudo nano /etc/hosts
    Code:
    127.0.0.1       localhost
    127.0.1.1      ub1204dk02
    
    # The following lines are desirable for IPv6 capable hosts
    ::1     ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    Replaced "ub1204dk02" with "mydomain.com" and rebooted

    $ sudo service apache2 restart
    Code:
    sudo: unable to resolve host ub1204dk02
     * Restarting web server apache2
    apache2: apr_sockaddr_info_get() failed for ub1204dk02
    apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
     ... waiting apache2: apr_sockaddr_info_get() failed for ub1204dk02
    apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
       ...done.
    Mistake still remains

    Edit:
    -----
    $ cat /etc/hostname
    Code:
    ub1204dk02
    changed "ub1204dk02" to "mydomain.com"

    $ sudo service apache2 restart
    Code:
     * Restarting web server apache2
     ... waiting    ...done.
    Now it works. Thanks


    B.R.
    satimis

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •