Find the answer to your Linux question:
Results 1 to 3 of 3
My Apache's authentication not working. I put this in the httpd.conf file: Code: <Location /resourcebase> AuthName "CSLucas Restricted. Please enter password." AuthType Basic AuthUserFile /var/cslucas/www01/users require valid-user </Location> Ask me ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2004
    Location
    In a shop
    Posts
    8

    Apache authentication not working


    My Apache's authentication not working. I put this in the httpd.conf file:
    Code:
    <Location /resourcebase>
        AuthName "CSLucas Restricted. Please enter password."
        AuthType Basic
        AuthUserFile /var/cslucas/www01/users
        require valid-user
    </Location>
    Ask me for any info about my settings

  2. #2
    Linux Newbie
    Join Date
    Dec 2004
    Location
    Barrie, Ontario
    Posts
    219
    If you put that in a .htacess file in the folder that you want to protect, does it work that way?
    Blog - KB5UMQ - Linux User #272983
    3 Rules:
    1) "It doesn't work..." is simply not useful information.
    2) Don't cross post!
    3) If you are asking for help, start by telling us your distro/os and version.

  3. #3
    Just Joined!
    Join Date
    Jan 2005
    Posts
    30
    "not working"
    When you access the folder do you get a login screen to insert the username
    and the password or you get inside the folder right away?

    /var/cslucas/www01/users
    This is a file? This file contains your user name and password? Did you use
    htpasswd to create that file?

    Where did you insert the "<Location /resourcebase> ..." in you httpd.conf

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •