Find the answer to your Linux question:
Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 30
Ok I've got the following apache packages on my box: Code: apache2 apache2-devel apache2-doc apache2-example-pages apache2-jakarta-tomcat-connectors apache2-mod_auth_mysql apache2-mod_fastcgi apache2-mod_macro apache2-mod_perl apache2-mod_python apache2-mod_ruby apache2-mod_prefork apache2-worker apache-ant libapr0 i downloaded all of ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Guru dylunio's Avatar
    Join Date
    Aug 2004
    Location
    Cymru
    Posts
    4,157

    Problems setting up Apache on SuSE 9.1


    Ok I've got the following apache packages on my box:
    Code:
    apache2
    apache2-devel
    apache2-doc
    apache2-example-pages
    apache2-jakarta-tomcat-connectors
    apache2-mod_auth_mysql
    apache2-mod_fastcgi
    apache2-mod_macro
    apache2-mod_perl
    apache2-mod_python
    apache2-mod_ruby
    apache2-mod_prefork
    apache2-worker
    apache-ant
    libapr0
    i downloaded all of these via YaST.

    Since this is my first time trying to use apache (so it would be useful if you could post some sites on it, Ihave looked around but with the overwhelming amount of material it's difficult to know what's good) I'm a bit lost.

    So I installed the above files, and have found my index files under /srv/www/htdocs and the httpd.conf in /etc/apache2/httpd.conf and I see that the port is set to port 80.

    But when I open a web browser I type http://localhost I get the following error:
    The connection was refused when attempting to contact localhost
    . reading around this sugests that apache isn't swiched on so I go to terminal and type
    Code:
    inux:/home/dylunio # httpd -k start
    bash: httpd: command not found
    .

    <edit> I'll add the return from
    Code:
    linux&#58;/home/dylunio # pidof httpd
    
    linux&#58;/home/dylunio #
    </edit>
    Anything I try with httpd at the begining or apachectl (these are the two commands I've tried with various things after them) get the 'command not found' error on both user and root.

    So what have I done wromg, or have to do to get apache up and running?

    Thanks;

    dylunio
    Registered Linux User #371543!
    Get force-get May The Source Be With You
    /dev/null
    /dev/null2

  2. #2
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    Code:
    whereis httpd
    then run the full path
    -lakerdonald

  3. #3
    Linux Guru dylunio's Avatar
    Join Date
    Aug 2004
    Location
    Cymru
    Posts
    4,157
    Ok this is the return from whereis httpd:
    Code:
    inux&#58;~ # whereis httpd
    httpd&#58; /etc/httpd
    But this is a directory and thus will not run, the outputs from putting start after it is:
    Code:
    inux&#58;~ # /etc/httpd start
    bash&#58; /etc/httpd&#58; is a directory
    linux&#58;~ #
    I've found the httpd.conf fine in /etc/apache2/httpd.conf, but when I try and run it (if this is what i'm suposed to run I get:
    Code:
    linux&#58;~ # /etc/apache2/httpd.conf start
    bash&#58; /etc/apache2/httpd.conf&#58; Permission denied
    thanks;

    dylunio
    Registered Linux User #371543!
    Get force-get May The Source Be With You
    /dev/null
    /dev/null2

  4. #4
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    go to the /etc/httpd directory.
    what's in there?
    it sounds like you didn't install apache correctly
    -lakerdonald

  5. #5
    Linux Guru dylunio's Avatar
    Join Date
    Aug 2004
    Location
    Cymru
    Posts
    4,157
    /etc/httpd contains:
    mailman.conf
    susehelp.conf
    susehelp.conf.old
    and the dir 'modules' which contains:
    mailman
    susehelp

    I'm suprised that apache is installed incorrectly, usualy YaSt does a good job of this.
    If you don't have any more suggestions I might try and reinstall via yast, and if I stall have trouble I'll compile the source;

    Thanks;

    dylunio
    Registered Linux User #371543!
    Get force-get May The Source Be With You
    /dev/null
    /dev/null2

  6. #6
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    yes, Yast usually does do a good job
    go ahead and reinstall
    -lakerdonald

  7. #7
    Linux Guru dylunio's Avatar
    Join Date
    Aug 2004
    Location
    Cymru
    Posts
    4,157
    I seem to be going someware with a httpd2 file I found:
    Code:
    linux&#58;~ # httpd2 start
    Usage&#58; httpd2 &#91;-D name&#93; &#91;-d directory&#93; &#91;-f file&#93;
                  &#91;-C "directive"&#93; &#91;-c "directive"&#93;
                  &#91;-k start|restart|graceful|stop&#93;
                  &#91;-v&#93; &#91;-V&#93; &#91;-h&#93; &#91;-l&#93; &#91;-L&#93; &#91;-t&#93; &#91;-S&#93;
    Options&#58;
      -D name           &#58; define a name for use in <IfDefine name> directives
      -d directory      &#58; specify an alternate initial ServerRoot
      -f file           &#58; specify an alternate ServerConfigFile
      -C "directive"    &#58; process directive before reading config files
      -c "directive"    &#58; process directive after reading config files
      -e level          &#58; show startup errors of level &#40;see LogLevel&#41;
      -E file           &#58; log startup errors to file
      -v                &#58; show version number
      -V                &#58; show compile settings
      -h                &#58; list available command line options &#40;this page&#41;
      -l                &#58; list compiled in modules
      -L                &#58; list available configuration directives
      -t -D DUMP_VHOSTS &#58; show parsed settings &#40;currently only vhost settings&#41;
      -S                &#58; a synonym for -t -D DUMP_VHOSTS
      -t                &#58; run syntax check for config files
    linux&#58;~ # httpd2 -k start
    httpd2&#58; could not open document config file /etc/apache2/sysconfig.d/include.conf
    Does any one know what I'm doing wrong?

    thanks;

    dylunio
    Registered Linux User #371543!
    Get force-get May The Source Be With You
    /dev/null
    /dev/null2

  8. #8
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    hmmm.
    well it's a start
    go ahead with the reinstall though
    -lakerdonald

  9. #9
    Linux Guru dylunio's Avatar
    Join Date
    Aug 2004
    Location
    Cymru
    Posts
    4,157
    Will do;

    dylunio
    Registered Linux User #371543!
    Get force-get May The Source Be With You
    /dev/null
    /dev/null2

  10. #10
    Linux Guru dylunio's Avatar
    Join Date
    Aug 2004
    Location
    Cymru
    Posts
    4,157
    I have the same problem after re-installing from YaST, which is that a file (/etc/apache2/sysconfig.d/include.conf) dosn't exist so the httpd2 -k start ill not work;

    I'll have a bash at installing the source;

    dylunio
    Registered Linux User #371543!
    Get force-get May The Source Be With You
    /dev/null
    /dev/null2

Page 1 of 3 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •