Find the answer to your Linux question:
Results 1 to 4 of 4
I've built a system to be a dedicated nas drive so i've loaded arch base with samba, sudo and openssh. the drive being shared is a seperate internal drive formated ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2013
    Posts
    3

    samba share problem "file or folder can not be found"


    I've built a system to be a dedicated nas drive so i've loaded arch base with samba, sudo and openssh. the drive being shared is a seperate internal drive formated to ext4. now I'm trying to share some folders on this share to everyone, without user or password promts but to no avail. when I try to access the folders i can see the workgroup and server string as well as the folder names but when i try to access the folders or put something into them I get "file or folder can not be found" error. does anyone have an idea on what is causing this problem?
    I've added the setup i'm using below.

    "smb.conf

    [global]
    workgroup = workgroup
    server string = nas
    security = user
    map to guest = Bad User
    guest ok = yes

    [documents]
    path = /mnt/NAS/Documents
    force user = nobody
    force group = nogroup
    read only = no
    create mask = 0777
    directory mask = 0777
    "

    "#ls -l /mnt/NAS
    drwxrwxrwx 2 nobody users 4096 jul 2 15:16 Documents
    "

  2. #2
    Just Joined!
    Join Date
    Mar 2013
    Posts
    7
    change SELINUX permission of shared directory that is available in "smb.conf" chcon -p ................. that is available in smb.conf ididnt remember and change in
    [global]
    security=share

  3. #3
    Just Joined!
    Join Date
    Jul 2013
    Posts
    3
    thanks but I don't have SELINUX on this system to change, it's just the arch base plus the packages i've already listed and I've tried security=share and still no change also the share option from my understanding is deprecated.

  4. #4
    Just Joined!
    Join Date
    Jul 2013
    Posts
    3
    ok I solve my own problem made a new guest account in group users with no pass then used # smbpasswd -an guest to add the user to samba and also in smb.conf under [global] I added "guest account = guest" then set the folders permissions to match the new guest account.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •