Find the answer to your Linux question:
Results 1 to 2 of 2
Hey! I get some errors on my vps.. It has debian 7.1 on it.. just upgraded it from 6.. and that's where the error came from.. when i do apt-get ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2013
    Posts
    1

    (Broken pipe) Stupid error on my VPS


    Hey!

    I get some errors on my vps.. It has debian 7.1 on it.. just upgraded it from 6.. and that's where the error came from..

    when i do apt-get upgrade i get this

    Code:
    :~# apt-get upgrade
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    You might want to run 'apt-get -f install' to correct these.
    The following packages have unmet dependencies:
     ia32-libs-i386:i386 : Depends: libgl1-mesa-dri:i386 (>= 7.7.1-5) but it is not installed
                           Depends: libsvga1:i386 (>= 1:1.4.3-29) but it is not installed
    E: Unmet dependencies. Try using -f.
    And when I force it with -f, I get this

    Code:
    (Reading database ... 43769 files and directories currently installed.)
    Unpacking libgl1-mesa-dri:i386 (from .../libgl1-mesa-dri_8.0.5-4+deb7u2_i386.deb) ...
    dpkg: error processing /var/cache/apt/archives/libgl1-mesa-dri_8.0.5-4+deb7u2_i386.deb (--unpack):
     trying to overwrite shared '/etc/drirc', which is different from other instances of package libgl1-mesa-dri:i386
    dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
    Unpacking libsvga1:i386 (from .../libsvga1_1%3a1.4.3-33_i386.deb) ...
    dpkg: error processing /var/cache/apt/archives/libsvga1_1%3a1.4.3-33_i386.deb (--unpack):
     trying to overwrite shared '/etc/vga/null.keymap', which is different from other instances of package libsvga1:i                          386
    dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
    Errors were encountered while processing:
     /var/cache/apt/archives/libgl1-mesa-dri_8.0.5-4+deb7u2_i386.deb
     /var/cache/apt/archives/libsvga1_1%3a1.4.3-33_i386.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    I usually solve my problems with google.. but this time, nothing seems to work..

    I installed the 32 bit libs and that's what caused it..
    I'd cladly remove it if it would help..

    Any suggestions what to try next?

  2. #2
    Linux User
    Join Date
    Dec 2011
    Location
    Turtle Island West
    Posts
    362
    I think you answered you own question.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •