Find the answer to your Linux question:
Results 1 to 3 of 3
I'm trying to setup samba authentication with a remote ldap server. I'm following these instructions: https://wiki.samba.org/index.php/Samba_&_LDAP Samba is asking for a login from windows but is not working and in ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2006
    Posts
    17

    Samba and LDAP


    I'm trying to setup samba authentication with a remote ldap server.

    I'm following these instructions: https://wiki.samba.org/index.php/Samba_&_LDAP

    Samba is asking for a login from windows but is not working and in the samba logs I see:

    Code:
    [2013/08/14 12:12:42.011320,  2] passdb/pdb_ldap.c:553(init_sam_from_ldap)
      init_sam_from_ldap: Entry found for user: Administrator
    [2013/08/14 12:12:42.016618,  2] passdb/pdb_ldap.c:2451(init_group_from_ldap)
      init_group_from_ldap: Entry found for group: 512
    [2013/08/14 12:12:42.023837,  0] passdb/passdb.c:2247(pdb_increment_bad_password_count)
      pdb_increment_bad_password_count: pdb_get_account_policy failed.
    [2013/08/14 12:12:42.023916,  2] passdb/pdb_ldap.c:1194(init_ldap_from_sam)
      init_ldap_from_sam: Setting entry for user: Administrator
    [2013/08/14 12:12:42.025426,  2] auth/auth.c:319(check_ntlm_password)
      check_ntlm_password:  Authentication for user [Administrator] -> [Administrator] FAILED with error NT_STATUS_WRONG_PASSWORD
    [2013/08/14 12:12:47.519584,  2] lib/smbldap.c:1018(smbldap_open_connection)
      smbldap_open_connection: connection opened
    [2013/08/14 12:12:47.528619,  2] passdb/pdb_ldap.c:553(init_sam_from_ldap)
      init_sam_from_ldap: Entry found for user: myuser
    [2013/08/14 12:12:47.592832,  2] passdb/pdb_ldap.c:2451(init_group_from_ldap)
      init_group_from_ldap: Entry found for group: 513
    [2013/08/14 12:12:47.594638,  2] passdb/pdb_ldap.c:2451(init_group_from_ldap)
      init_group_from_ldap: Entry found for group: 513
    [2013/08/14 12:12:47.606420,  1] auth/server_info.c:391(samu_to_SamInfo3)
      The primary group domain sid(S-1-5-21-3048799883-1163886831-XXXXXXXXXX-513) does not match the domain sid(S-1-5-21-3692295675-382424995-XXXXXXXXXX) for myuser(S-1-5-21-3692295675-382424995-XXXXXXXXXX-4656)
    [2013/08/14 12:12:47.606482,  0] auth/check_samsec.c:491(check_sam_security)
      check_sam_security: make_server_info_sam() failed with 'NT_STATUS_UNSUCCESSFUL'
    [2013/08/14 12:12:47.606577,  2] auth/auth.c:319(check_ntlm_password)
      check_ntlm_password:  Authentication for user [myuser] -> [myuser] FAILED with error NT_STATUS_UNSUCCESSFUL

    Please help me, I'm getting mad...

  2. #2
    Just Joined!
    Join Date
    Feb 2012
    Posts
    12
    I looked at that link and those instructions are rather poor. Try this link instead: help.ubuntu.com/10.04/serverguide/samba-ldap.html, and let us know how it goes.

  3. #3
    Just Joined!
    Join Date
    Nov 2006
    Posts
    17
    The openldap server is already up & running and it is working with other samba machines.
    I think I almost configured samba correctly but I'm missing something I can't figure out.
    And I can't find valid informations by googling with error log messages...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •