Find the answer to your Linux question:
Results 1 to 9 of 9
Hello Forum, My server is Centos 7 (64bit - 8GB - 8core) and apache 2.4.6. It's configured with multiple vhost (about 5000). If I try to start from service (service ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2009
    Posts
    10

    Apche multiple vhost dont start


    Hello Forum,

    My server is Centos 7 (64bit - 8GB - 8core) and apache 2.4.6.

    It's configured with multiple vhost (about 5000).

    If I try to start from service (service httpd start) dont works.

    But, if I try from command line "httpd -h start" it works fine.

    Same configuration on other server with CentOS 6.5 works fine.

    There is a limit of number of vhost? How can I solve this problem?

    Thanks

    Robbtek

  2. #2
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,934
    Quote Originally Posted by robbtek View Post
    If I try to start from service (service httpd start) dont works.
    How does 'dont works' manifest - what do you see? If it does provide some kind of error message can you capture it and post it up here?

    What output do you see after starting the service and causing the failure, then trying:

    Code:
    service httpd status
    Does the process of starting Apache give you any information in the logs? Take a look in /var/log/httpd/... The log files may be different for each vhost, but the main log error file should have details of any failures recorded in it. If you can't decipher these, then by all means post those here too and we'll do what we can.
    Linux user #126863 - see http://linuxcounter.net/

  3. #3
    Just Joined!
    Join Date
    Mar 2009
    Posts
    10
    There's no output ... I must start apache from command line with "ulimit -n 65000 ; httpd -k start' or go back to server with CentOS 6.5.

  4. $spacer_open
    $spacer_close
  5. #4
    Penguin of trust elija's Avatar
    Join Date
    Jul 2004
    Location
    Either at home or at work or down the pub
    Posts
    3,653
    Try systemctl start httpd.service instead of service ... and to start it at boot time systemctl enable httpd.service
    "I used to be with it, then they changed what it was.
    Now what was it isn't it, and what is it is weird and scary to me.
    It'll happen to you too."

    Grandpa Simpson



    The Fifth Continent

  6. #5
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,934
    Quote Originally Posted by robbtek View Post
    There's no output ... I must start apache from command line with "ulimit -n 65000 ; httpd -k start' or go back to server with CentOS 6.5.
    What appears in the Apache logs?
    Linux user #126863 - see http://linuxcounter.net/

  7. #6
    Just Joined!
    Join Date
    Mar 2009
    Posts
    10
    systemctl enable httpd.service dont works.

    systemctl start httpd.service and service httpd start dobt works.

    httpd -k start its only solution to start web server.

    In apache log, appear only "Cant ope log".

  8. #7
    Penguin of trust elija's Avatar
    Join Date
    Jul 2004
    Location
    Either at home or at work or down the pub
    Posts
    3,653
    Can you post the relevant section of the log?
    "I used to be with it, then they changed what it was.
    Now what was it isn't it, and what is it is weird and scary to me.
    It'll happen to you too."

    Grandpa Simpson



    The Fifth Continent

  9. #8
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,934
    You need admin privileges to read the logs. Either 'su' to the root user at the command line, or use 'sudo'. Likewise you need this privilege to start and stop services, which could be the cause of the issue you're seeing.
    Linux user #126863 - see http://linuxcounter.net/

  10. #9
    Penguin of trust elija's Avatar
    Join Date
    Jul 2004
    Location
    Either at home or at work or down the pub
    Posts
    3,653
    Quote Originally Posted by Roxoff View Post
    You need admin privileges to read the logs. Either 'su' to the root user at the command line, or use 'sudo'. Likewise you need this privilege to start and stop services, which could be the cause of the issue you're seeing.
    That's a thought which I hadn't considered. If using sudo (on Fedora 20) you still can't read the logs unless you run sudo -i which gives you the full root environment.
    "I used to be with it, then they changed what it was.
    Now what was it isn't it, and what is it is weird and scary to me.
    It'll happen to you too."

    Grandpa Simpson



    The Fifth Continent

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •