Find the answer to your Linux question:
Results 1 to 3 of 3
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2014
    Posts
    3

    Samba share problem


    Hi all.
    Sorry if this is posted in the wrong area, as I am new to Linux stuff.

    I have a Netgear ReadyNAS that runs Samba.
    I set up an admin account that has access to the root folder on my raid set. It's a subfolder in the admins home folder. That works well.

    Now comes my problem.
    In that folder I have ANOTHER subfolder, which I want guest users to have read/execute access to WITHOUT password.
    My administrator account works as intended, but can't get the guest account to work.

    Below is a copy of my smb.conf
    ROOT is a subfolder in the admin's home folder. The admin have full rights to that folder and all subfolders.
    Data is a subfolder in the ROOT folder. This is the one I want guests to be able to read.
    Code:
    security = user
    encrypt passwords = yes
    smb passwd file = /etc/samba/smbpasswd
    use sendfile = yes
    
    guest account = nobody
    
    printcap name = cups
    load printers = yes
    printing = cups
    
    socket options = TCP_NODELAY SO_RCVBUF=65536 SO_SNDBUF=65536
    dns proxy = no
    
    browseable = yes
    map to guest = Bad User
    
    domain master = no
    local master = yes
    preferred master = yes
    os level = 2
    unix charset = UTF8
    unix extensions = no
    mangled names = no
    
    # We need this here to prevent errors from appearing in WinXP
    # https://listman.redhat.com/archives/redhat-list/2003-January/msg00939.html
    use client driver = yes
    
    log level = 0
    
    
    # This section is only included if home folder sharing is enabled
    
    [ROOT]
    comment = Stora (ROOT)
    path = /home/%U/ROOT
    browsable = yes
    writable = yes
    valid users = administrator
    create mode = 0664
    directory mode = 0775
    force create mode = 0664
    force directory mode = 0775
    force security mode = 0775
    force group = www
    guest ok = no
    
    [Data]
    comment = Stora (Data)
    path = /home/administrator/ROOT/xSHAREDx
    valid users = anyone, administrator
    browsable = yes
    read only = yes
    public = yes
    guest ok = yes
    guest account = nobody

  2. #2
    Just Joined!
    Join Date
    Aug 2014
    Posts
    3
    I can see a lot of people have read this, but is there nobody who can help?

  3. #3
    Just Joined!
    Join Date
    Aug 2014
    Posts
    3
    Well you can forget this question... Found the solution by trial and error...

    As this forum seems dead anyway then I am leaving it again...
    have fun whoever...

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •