Find the answer to your Linux question:
Results 1 to 2 of 2
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Squirrelmail getting 'from' email address wrong


    I am running Sendmail and dovecot on very old Fedora 3 distro. I also installed SquirrelMail leaning on the mail server and providing me with web interface.

    Problem I found is that whenever I send message with Squirrel it goes out with my linux address, not mail address.

    For example my mail is,

    but receiving party sees address with my actual linux username :

    Thunderbird works fine, this is the Squirrel problem only.

    I did not find any information on it, overall Squirrel support is very poor. I tried change named.conf but failed to fix. I will be so grateful for help!


  2. #2
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Nottingham, England
    I moved you to an new thread all of your own...

    It's been a while since I used Squirrelmail - I use Roundcube now (it's is a lot nicer, but more server intense), so this is from memory. In the user configuration for your squirrelmail account (after you've logged in through the web interface) you get to manipulate your chosen preferences. I believe in there you can set your return email address that it uses in the email. It's part of the account configuration. I think you can even specify several return addresses and select which one you want to use when you're composing an email.

    On a side note - Fedora 3 is very, very old now and waaay out of support. You should consider an upgrade - and as it's a mailserver, you might want to look at moving to CentOS, which is a free version of RedHat Enterprise server os. As both Fedora and CentOS are both RedHat systems, you should find things very familiar. And 'cos it's a server OS it's support time is far longer than Fedora's.
    Linux user #126863 - see

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts