Find the answer to your Linux question:
Results 1 to 9 of 9
I run Arch Linux and SSHD works fine offsite. Wherever I go during the day I can always login. However, when I get home at night and I try to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2005
    Posts
    4

    SSHD LAN connection lagging big time!


    I run Arch Linux and SSHD works fine offsite. Wherever I go during the day I can always login. However, when I get home at night and I try to ssh into my box from another machine on the local network; ie:

    ssh -l oram 192.168.1.109

    It almost always comes back with 'connection closed' or when it does work, it is slow as hell. I have tried to figure this out but I can seem to make any progress. I usually connect to the linux box with a powermac running OSX[/b]

  2. #2
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    Try running a ping -c4 and a tracepath to the Linux box. Post the output here.
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  3. #3
    Just Joined!
    Join Date
    Jan 2005
    Posts
    4

    my wish is your command

    nobook:~ me$ ping -c4 192.168.1.109
    PING 192.168.1.109 (192.168.1.109): 56 data bytes
    64 bytes from 192.168.1.109: icmp_seq=0 ttl=64 time=1.502 ms
    64 bytes from 192.168.1.109: icmp_seq=1 ttl=64 time=3.117 ms
    64 bytes from 192.168.1.109: icmp_seq=2 ttl=64 time=3.777 ms
    64 bytes from 192.168.1.109: icmp_seq=3 ttl=64 time=8.123 ms

    --- 192.168.1.109 ping statistics ---
    4 packets transmitted, 4 packets received, 0% packet loss
    round-trip min/avg/max = 1.502/4.129/8.123 ms

  4. #4
    Linux Enthusiast puntmuts's Avatar
    Join Date
    Dec 2004
    Location
    Republic Banana
    Posts
    562
    You could specify the -v option to look at the debug messages. More v's is more info
    Maybe that way you could see where the delay is..
    I\'m so tired .....
    #200472

  5. #5
    Just Joined!
    Join Date
    Jan 2005
    Posts
    4
    nobook:~ nick$ ssh -l nick 192.168.1.109 -v
    OpenSSH_3.6.1p1+CAN-2004-0175, SSH protocols 1.5/2.0, OpenSSL 0x0090702f
    debug1: Reading configuration data /etc/ssh_config
    debug1: Rhosts Authentication disabled, originating port will not be trusted.
    debug1: Connecting to 192.168.1.109 [192.168.1.109] port 22.
    debug1: Connection established.
    debug1: identity file /Users/nick/.ssh/identity type -1
    debug1: identity file /Users/nick/.ssh/id_rsa type -1
    debug1: identity file /Users/nick/.ssh/id_dsa type -1
    debug1: Remote protocol version 1.99, remote software version OpenSSH_3.9p1
    debug1: match: OpenSSH_3.9p1 pat OpenSSH*
    debug1: Enabling compatibility mode for protocol 2.0
    debug1: Local version string SSH-2.0-OpenSSH_3.6.1p1+CAN-2004-0175
    debug1: An invalid name was supplied
    Cannot determine realm for numeric host address

    debug1: An invalid name was supplied
    A parameter was malformed
    Validation error

    debug1: An invalid name was supplied
    Cannot determine realm for numeric host address

    debug1: An invalid name was supplied
    A parameter was malformed
    Validation error


    debug1: SSH2_MSG_KEXINIT sent
    debug1: SSH2_MSG_KEXINIT received
    debug1: kex: server->client aes128-cbc hmac-md5 none
    debug1: kex: client->server aes128-cbc hmac-md5 none
    debug1: SSH2_MSG_KEX_DH_GEX_REQUEST sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
    debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
    debug1: Host '192.168.1.109' is known and matches the RSA host key.
    debug1: Found key in /Users/nick/.ssh/known_hosts:7
    debug1: ssh_rsa_verify: signature correct
    debug1: SSH2_MSG_NEWKEYS sent
    debug1: expecting SSH2_MSG_NEWKEYS
    debug1: SSH2_MSG_NEWKEYS received
    debug1: SSH2_MSG_SERVICE_REQUEST sent
    debug1: SSH2_MSG_SERVICE_ACCEPT received
    debug1: Authentications that can continue: publickey,password,keyboard-interactive
    debug1: Next authentication method: publickey
    debug1: Trying private key: /Users/nick/.ssh/identity
    debug1: Trying private key: /Users/nick/.ssh/id_rsa
    debug1: Trying private key: /Users/nick/.ssh/id_dsa
    debug1: Next authentication method: keyboard-interactive
    debug1: Authentications that can continue: publickey,password,keyboard-interactive
    debug1: Next authentication method: password
    nick@192.168.1.109's password:
    debug1: Authentication succeeded (password).
    debug1: channel 0: new [client-session]
    debug1: Entering interactive session.
    debug1: channel 0: request pty-req
    debug1: channel 0: request shell
    debug1: channel 0: open confirm rwindow 0 rmax 32768
    Last login: Tue Jan 11 20:31:13 2005 from blk-222-152-173.eastlink.ca
    Welcome to Frank The Tank!
    [nick@frank ~]$

    From here i am inside the box, however, the text highlighted in red is where the shelling in seems to hang.

  6. #6
    Just Joined!
    Join Date
    Feb 2004
    Location
    Bangalore
    Posts
    14
    For this you have to add your home_pc_IP to the /etc/hosts.allow

    or Allow your ip in /etc/sshd_config like this

    AllowHosts your Home ip


    Try this....................

  7. #7
    Just Joined!
    Join Date
    Jan 2005
    Posts
    4

    this is what my /etc/host.allow file looks like now

    #let everyone connect to you
    sshd: ALL
    sshd: 192.168.1.100/192.168.1.254

    #Or you can restrict it to a certain ip
    #sshd: 192.168.1.100
    #Or restrict it to a certain ip range
    #sshd: 10.0.0.0/255.255.255.0

    EOF

    the highlighted line is what i added upon your request. I thought i'd add all the possible router ip's. This still doesn't make a difference. I'm thinking that there is some kind of problem with the "A parameter was malformed" error line above from debug: 1

    Thanks

  8. #8
    Just Joined!
    Join Date
    Feb 2005
    Posts
    1
    I am having an identical problem with my Powermac G4 and Powerbook. The problem appeared in mid January, and I have tried everything to fix it. My "ssh -v" log looks exactly like yours.

    Has anybody else experienced this problem?

    Zack

  9. #9
    Linux Engineer adrenaline's Avatar
    Join Date
    Aug 2004
    Location
    Seattle, Washington
    Posts
    1,058
    Reading over this thread maybe I am confused but in the original post you logged in as oram and the second one you logged in as nick Did you mean to do that and is nick a username on the box you are trying to ssh to?
    Some people have told me they don't think a fat penguin really embodies the grace of Linux, which just tells me they have never seen a angry penguin charging at them in excess of 100mph. They'd be a lot more careful about what they say if they had.
    -- Linus Torvalds

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •