Find the answer to your Linux question:
Results 1 to 4 of 4
Does anyone have any idea why my smb config doesn't ever work? When I try using localhost:631, it gives unable to connect SAMBA host. Now i've learnt a new way ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2004
    Posts
    47

    printer sharing problems (from winxp box)


    Does anyone have any idea why my smb config doesn't ever work? When I try using localhost:631, it gives unable to connect SAMBA host.

    Now i've learnt a new way of testing it using smbclient, but it gives me a lot of errors. The windows box is named "Computer", User "User", No password. Workgroup "ABC" (which is also changed in samba.conf)

    none of these commands can even connect...
    Code:
    [root@localhost samba]# smbclient -you user -L Computer
    Connection to Computer failed
    [root@localhost samba]# smbclient -you User -L Computer
    Connection to Computer failed
    [root@localhost samba]# smbclient -you user -L computer
    Connection to computer failed
    [root@localhost samba]# smbclient -you User -L computer
    Connection to computer failed

    I tried then using the ip addy of the windows box..

    Code:
    [root@localhost samba]# smbclient -you user -L 192.168.2.101
    Password:
    Domain=[COMPUTER] OS=[Windows 5.1] Server=[Windows 2000 LAN Manager]
    
            Sharename       Type      Comment
            ---------       ----      -------
            IPC$            IPC       Remote IPC
            D$              Disk      Default share
            print$          Disk      Printer Drivers
            hpLaserJ        Printer   hp LaserJet 1010 Series Driver
            Z$              Disk
            ABBIE (D)       Disk
            ADMIN$          Disk      Remote Admin
            C$              Disk      Default share
    session request to 192.168.2.101 failed (Called name not present)
    session request to 192 failed (Called name not present)
    Domain=[COMPUTER] OS=[Windows 5.1] Server=[Windows 2000 LAN Manager]
    
            Server               Comment
            ---------            -------
    
            Workgroup            Master
            ---------            -------
    [root@localhost samba]#

    As you can see, I have some failures there? What do they mean? And how come I need to use the ip, and I can't use the box name?

    Can someone also give me the proper smb:// command? I've tried everything and can't get this damn printer to connect.

  2. #2
    Linux Engineer adrenaline's Avatar
    Join Date
    Aug 2004
    Location
    Seattle, Washington
    Posts
    1,058
    Is the printer shared out on the windows box?
    All you need to do to get smb to work is to match the workgroup name with the windows box create usernames and passwords to match and create samba usernames and passwords to match those
    smbpasswd -a <username>

    then start the service.
    <different distros start different ways but in Red Hat its
    /etc/init.d/smbd restart Assuming it is installed.

    IN Slackware it is
    /etc/rc.d/rc.samba restart
    Some people have told me they don't think a fat penguin really embodies the grace of Linux, which just tells me they have never seen a angry penguin charging at them in excess of 100mph. They'd be a lot more careful about what they say if they had.
    -- Linus Torvalds

  3. #3
    Just Joined!
    Join Date
    Dec 2004
    Posts
    47
    the username on the winxp box is user. The workgroup is abc, which i changed in the smbd.conf.

    Code:
    &#91;root@localhost ~&#93;# smbpasswd -a user
    New SMB password&#58;
    Retype new SMB password&#58;
    Failed to initialise SAM_ACCOUNT for user user. Does this user exist in the UNIX password database ?
    Failed to modify password entry for user user
    &#91;root@localhost ~&#93;#
    Still does not see winxp box unless i use ip method. (which I cannot use permanently)

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jun 2004
    Location
    Leiria - Portugal
    Posts
    72

    Unix and samba users

    The users used by samba need to exist!

    You 1st create them in your unix box and at a 2nd step you'll activate them for samba use.

    The far you can get is using maped users, /etc/samba/smbusers.

    Try to read man samba, you will find it the most usefull help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •