Find the answer to your Linux question:
Results 1 to 3 of 3
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Question Cant login in to my vsFTPd server via Web Browser

    I installed vsftpd with the command apt install vsftpd . The server is running and I can connect and log in,
    but only in the linux shell. If I try it on the Firefox web browser i get this error :
    550 Failed to change directory.
    I don't even know what this error mean and I didn't find anything helpful on the Internet until now.

    I used the user FTP to login, he should have full access to the server because I added him to the chroot list.

    I read the vsftp man page and I read tutorials but they all stopped at the point where they have logged in successfully with the linux shell but never with the web browser so I never saw it....

    The problem is, i want a connection with the server from a other computer, to upload some files from there, but i don't know how ,if i can not login ,...and yes i will setup and use SSL after that (I wrote this because some people said I should do this because it's safer).

    I tried to list the directories with a linux shell command ls -a and it worked, so my problem is that I cant login via web browser:

     Select all
    200 EPRT command successful. Consider using EPSV.
    150 Here comes the directory listing.
    drwxr-xr-x 2 1000 1000 4096 Jun 15 13:06 .
    drwxr-xr-x 3 0 0 4096 Jun 15 13:06 ..
    -rw-r--r-- 1 1000 1000 220 Jun 15 13:06 .bash_logout
    -rw-r--r-- 1 1000 1000 3391 Jun 15 13:06 .bashrc
    -rw-r--r-- 1 1000 1000 3526 Jun 15 13:06 .bashrc.original
    -rw-r--r-- 1 1000 1000 675 Jun 15 13:06 .profile
    226 Directory send OK.

  2. #2
    why do you think that you can use vsftpd through a web browser?
    is this possible with additional configuration maybe?
    did you read the documentation?

    if you still need help, please explain in all detail all steps you took (installation, configuration, etc.) to arrive at the present situation.
    Tapatalk: Kill it with fire!
    How to ask smart questions | Don't be a Help Vampire | How to Use Code Tags
    You can post a link by removing "http://www." from it.

  3. #3

    No ,the problem is solved! i tried to connect with
    ftp:// [hostname]/[localhost] not with just ftp:// [hostname] XD this was my fault haha......

  4. $spacer_open

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts