Find the answer to your Linux question:
Results 1 to 6 of 6
I have a primary master name server and a slave name server. When a start the slave server I get the following error: Jan 31 17:42:41.799 dumping master file: /etc/named/tmp-XXXX2RSNyT: ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2005
    Location
    Germany
    Posts
    69

    Bind 9 - zone transfer - permission denied


    I have a primary master name server and a slave name server.
    When a start the slave server I get the following error:

    Jan 31 17:42:41.799 dumping master file: /etc/named/tmp-XXXX2RSNyT: open: permission denied
    Jan 31 17:42:41.799 transfer of 'mydomain.com/IN' from 192.168.3.1#53: failed while receiving responses: permission denied


    On the master server the zone files has 744 permissions set and is own by root.


    Why do I get this permission error if the files have set Read access for everybody?


    Thanks,
    ddaas

  2. #2
    Linux Engineer
    Join Date
    Nov 2004
    Location
    Montreal, Canada
    Posts
    1,267
    dumping master file: /etc/named/tmp-XXXX2RSNyT
    is it trying to write into the Tmp file...
    have you tryed different rights
    \"Meditative mind\'s is like a vast ocean... whatever strikes the surface, the bottom stays calm\" - Dalai Lama
    \"Competition ultimatly comes down to one thing... a loser and a winner.\" - Ugo Deschamps

  3. #3
    Just Joined!
    Join Date
    Jan 2005
    Location
    Germany
    Posts
    69
    I don't know why it tries to write into a tmp file.
    No I didn't try different rights because it's a production server and I'm concerned about security.
    The read right should be enough....

    Any idea??

  4. #4
    Just Joined!
    Join Date
    May 2005
    Posts
    3
    I had a similar problem and changed the permissions so that named owned the files. Mine works now!

  5. #5
    Linux Newbie
    Join Date
    Mar 2005
    Posts
    230
    slave zones require a writeable directory cause BIND automatically creates and writes to the slave zone file. With tight implementations of BIND security, there is a directory setup for slave and dynamic zones specifically and the master zones go into their own read-only directory.

  6. #6
    Just Joined!
    Join Date
    Feb 2009
    Posts
    1

    Solved!

    You need to put 'ENABLE_ZONE_WRITE=yes' in /etc/sysconfig/named .
    By default, write of master zone files is disabled

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •