Find the answer to your Linux question:
Page 2 of 3 FirstFirst 1 2 3 LastLast
Results 11 to 20 of 23
you will have to use your linux machine's internal ip in httpd.conf with virtualnamehost. do a #/sbin/ifconfig -a and assign the ip address that you get there. Do you have ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux User
    Join Date
    May 2003
    Location
    CA
    Posts
    370

    you will have to use your linux machine's internal ip in httpd.conf with virtualnamehost.
    do a
    #/sbin/ifconfig -a
    and assign the ip address that you get there.
    Do you have any other local machines connected to your router?

  2. #12
    Just Joined!
    Join Date
    Jun 2003
    Posts
    50
    Yes, I have other machines connected to the router. But they have nothing to do with the webserver. Just machines for browsing the net.
    I thought I already tried using machine's internal ip, but I'll try again tonight. I also did search on the net for my problem... read alot lately. Seems many people have the same issue... I will give it another try, if I can't get it working... think I try reinstalling it this weekend.

  3. #13
    Linux User
    Join Date
    May 2003
    Location
    CA
    Posts
    370
    I'll try the same this week and will keep you posted. I have apache installed, I'll get a domain name from dyndns and keep you posted on the developments.
    By the way can the other local machines access your webserver by typing the ip address? and by typing the server name?

  4. $spacer_open
    $spacer_close
  5. #14
    Just Joined!
    Join Date
    Jun 2003
    Posts
    50
    Hey nikhil,
    I finally figured it out! My virtual name hosts are working. It was the line
    "Include config.d/*.cfg" Once I get this directive commented, my virtual name host resolves. Now, I just gotta figure out which of those config files are causing it. I think it might be the SSL one... even though I don't load SSL on my box...hmm... will see what happens. Thanks alot again for you help.

  6. #15
    Just Joined!
    Join Date
    Jun 2003
    Posts
    50
    I found the setting thats causing my virtual host not to resolve. Is the php.conf file and the directive "DirectoryIndex index.php". I comment out this directive and my virtual host works fine. Can someone explain this to me? Maybe because I don't have the index.php in my Document root? Thats why it automatically loads the default test page??? Hmmm... I will create the index.php file and see what happens.

  7. #16
    Just Joined!
    Join Date
    Jun 2003
    Posts
    50
    yup thats it! The php.conf directive "DirectoryIndex index.php" overides the main directoryindex. It all makes sense now. Many thanks and I gain some knowledge =)

  8. #17
    Linux User
    Join Date
    May 2003
    Location
    CA
    Posts
    370
    cool...dont you have many files in the DirectoryIndex directive like
    index.html,index.shtml,index.php...I guess this way if it does not find index.php it will move on to the next in the list.

  9. #18
    Just Joined!
    Join Date
    Jun 2003
    Posts
    50
    yeah... now I know. I never knew that php.conf contains the DirectoryIndex directive also. Now I am working on securing my site. I only know 2 basics... one is to limit the info on the server and turning off directory indices. Any other tips? There seems to be so many different kind of authentications. I gotta figure out which one is best. Also SSL doesn't work with virtual name hosts right?

  10. #19
    Linux User
    Join Date
    May 2003
    Location
    CA
    Posts
    370
    SSL does work with virtual name hosts. I have two different sites running one on http and the other on https.
    Try the following lines in your httpd.conf file, modify them accodring to your config.

    <VirtualHost ip-addressort number>
    SSLEngine off
    ServerAdmin
    ServerName
    DocumentRoot
    </VirtualHost>


    Using the order allow,deny along with .htaccess and .htpasswd file seems to be one way of securing your webserver instance, there might be many other diff ways as well.

  11. #20
    Just Joined!
    Join Date
    Jun 2003
    Posts
    50
    Cool, thanks alot for the tips nikhil. I will fool around with it. I will post new messages when I run into bumps. Take care for now.

Page 2 of 3 FirstFirst 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •