Find the answer to your Linux question:
Page 2 of 3 FirstFirst 1 2 3 LastLast
Results 11 to 20 of 21
CPU Rates: .3% user .5% system 0.0% nice 99.4%idle The machine itself is a P3 1Ghz running Redhat 7.3...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    Jun 2003
    Location
    Canada eh?
    Posts
    16

    CPU Rates: .3% user .5% system 0.0% nice 99.4%idle

    The machine itself is a P3 1Ghz running Redhat 7.3

  2. #12
    Linux Guru
    Join Date
    Apr 2003
    Location
    London, UK
    Posts
    3,284
    Ive been thinking about the for the last couple of days, are you running these daemons inside inetd or standalone?

    Inetd will start the server each time a request is made that the is assigned to handle, then unload the server once finished processing the request.

    It would certainly be a possibility that this is causing the slow initial connections.

    Jason

  3. #13
    Just Joined!
    Join Date
    Jun 2003
    Location
    Canada eh?
    Posts
    16
    Hmm, possibly.
    I feel dumb asking this, but how would I check?

    I chose to install Apache, Anonymous FTP, Telnet, etc... when I initially installed Redhat.
    If the were the case though, it should have been slow all along, not just in the past week and a half.

    Last night, around 2am (est) the website, FTP logon, etc.. were running a lot faster (not back to their originally speed, but definatly faster). Yet thismorning, they are back to the slow initial connect.
    I checked the running processes last night, and there is nothing new, or missing.

    I appreciate you giving extra thought to the problem, it's got me

  4. #14
    Linux Guru
    Join Date
    Apr 2003
    Location
    London, UK
    Posts
    3,284
    for RH im not too sure, do you have a /etc/inetd.conf file?

    if you do, you will proberly see a line in their like:
    "ftp stream tcp nowait root /usr/sbin/tcpd proftpd" for the ftp server if your server is proftpd, or for apache a similar line but with http at the front instead of ftp.

    Jason

  5. #15
    Just Joined!
    Join Date
    Jun 2003
    Location
    Canada eh?
    Posts
    16
    I did a bit of google searching, Redhat changes inetd.conf to xinetd.conf

    In this file, I have just a few lines:

    instances=60
    log_type= SYSLOG authpriv
    log_on_success = HOST PID
    etc...

    and a line including /etc/xinetd.d

    This sub diretory contains wu-ftpd, telnet, talk, time, rlogin, etc...

    Each of these files is the same format as xinetd.conf.

    telnet for example contains:

    service telnet
    {
    disable=no
    flage=REUSE
    socket_type=stream
    wait=no
    user=root
    server=/usr/sbin/in.telnetd
    log_on_failure += USERID
    }

  6. #16
    Linux Guru
    Join Date
    Apr 2003
    Location
    London, UK
    Posts
    3,284
    That would indicate the telnet daemon is in xinetd, and running that way, so connections to the telnet port (23) would be slower than if this was running as a standalone server. Same for wu-ftp if "disabled=no" in that file.

    You didnt mention apache/web server? so this may indicate that it is running as a standalone server, so their is no reason for this to run as slow as it appears to.

    You also mentioned that it was back to almost normal speed for a short period of time? i am starting to thing along the lines of network congestion.

    Install this software, and let it run for a day, then post up a link to a page with the graphs on it: http://people.ee.ethz.ch/~oetiker/webtools/mrtg/ if your machine has access to SNMP of any of your upstream routers, configure it to monitor those as well.

    Jason

  7. #17
    Just Joined!
    Join Date
    Jun 2003
    Location
    Canada eh?
    Posts
    16
    YEs, HTTPD (or any reference to Apache) was not in the xinetd.d directory.

    Yesterday the server was running at full speed again, initial connections were instant for HTTPD, FTP, and Telnet.

    I had not made any changes, it just started working.

    But today, it's back to the ultra slow initial conection...

    Thanks for the link, I'll run that and post the link.

    I know I keep saying it, but I really do appreciate the help!

  8. #18
    Just Joined!
    Join Date
    Jun 2003
    Location
    Canada eh?
    Posts
    16
    Just wanted to post an update on the problem.

    The server is back up to full speed!

    http://www.jaggedpath.com

    It turns out that is was my ISP after all.
    Their DNS was timing out when performing reverse lookups, so you had to wait for that time out when initially connecting to a service on the server.

    It wasn't until more people in the building started to complain about the slowness on their own servers that the ISP did anything about it, but hey, it's fixed now.

    Thanks to all who helped me with this!
    Greatly appreciated!
    If you're ever in Toronto, I'll buy you a pint

  9. #19
    Linux Guru
    Join Date
    Apr 2003
    Location
    London, UK
    Posts
    3,284
    Good news, brillient

    Quote Originally Posted by happydude
    Thanks to all who helped me with this!
    Greatly appreciated!
    If you're ever in Toronto, I'll buy you a pint
    Cheers,

    Feel free to stick around these forums, its always good to have server admins around

    Jason

  10. #20
    Linux User
    Join Date
    Jun 2003
    Location
    Calgary, AB CANADA
    Posts
    496
    Quote Originally Posted by happydude
    The server is back up to full speed!
    Ah yes, much better now! Nice to know it wasn't something you did - but damn those ISPs, eh?

    P.S. I know a couple of the guys that run a similar site for out here in the west: www.pinkbike.com

Page 2 of 3 FirstFirst 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •