Find the answer to your Linux question:
Results 1 to 8 of 8
Hi all, I am running SUSE ES9 on a Dell PE Server. I have set a common folder to be shared from all machines on the LAN via Samba. All ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2004
    Posts
    15

    Samba+Windows 2000


    Hi all,

    I am running SUSE ES9 on a Dell PE Server. I have set a common folder to be shared from all machines on the LAN via Samba. All the XP Pro machines can see it in the network neighborhood but I have just mapped the folder as a drive on the Windows machines so it is easily accesable from "my computer".

    Our lone Windows 2000 machine can also see it but not access it either from NN or as a mapped drive. If you click on it, the machine simply hangs for a few seconds. These machines can ping each other and no firewall is in place. The Windows 2000 machine was not set up with a login or password (not my doing) but neither are any of the XP machines.

    All the posts I have found on the Internet deal with machines that either cannot even see the Samba machine or have login failure but not the problem I am having. I have added no users to Samba but again none of the XP machines seem to have any issue with it. Samba asks for a user ID and password when the XP machines first connect and I used the same ones that I use to login the Suse machine with. I just clicked "remember password" and "reconnect on startup" and it seems to work fine.

    On a curious note I did have a similar issue on a Windows ME machine I was experimenting with. It would ask for a password only and not a login so it too would fail. I tried making a profile on the Win Me machine with no joy.

    Any ideas?

    Jim

  2. #2
    Just Joined!
    Join Date
    Feb 2005
    Posts
    12
    can you post your smb.conf?

  3. #3
    Linux Engineer adrenaline's Avatar
    Join Date
    Aug 2004
    Location
    Seattle, Washington
    Posts
    1,058
    You need to add a line in your [global] section saying encrypted passwords =yes and you need to add the users to the smbpasswd file
    smbpasswd -a username
    should do the trick

    Mike

    Also make sure the 2k machine is on the same workgroup/domain as the xp machines.
    Some people have told me they don't think a fat penguin really embodies the grace of Linux, which just tells me they have never seen a angry penguin charging at them in excess of 100mph. They'd be a lot more careful about what they say if they had.
    -- Linus Torvalds

  4. #4
    Linux Newbie
    Join Date
    Feb 2005
    Posts
    129
    Take a look here, too.

  5. #5
    Just Joined!
    Join Date
    May 2004
    Posts
    15
    Thanks for the feedback,

    I added the registry hack to disable encrypted passwords for Windows 2000 but to no avail.

    I do not have any users to add, or I should say how I am attempting this should not need them I don't think. If you want to know I will tell you the setup but frankly it's sort of a first attempt and is SURELY not how I am supposed to be doing it. I am also using the GUI totally. I have used VI to edit files before in Debian but I must say it was a chore for a novice like me.

    All the XP machines login to the desktop on their own (and they work) and the 2K machine uses admin and no password. I did try making a user on the 2K machine using the same login and pass as the Linux box but it does not work.

    I did make progress to the point that when I try to map the drive and ask for a user and pass but then declares "the resource is not available" (or similar).

    I also tried using both the \\IP address\share and
    \\machine name\share format with no luck.

    They are all in the same workgroup and the other XP machines can share files and printers with the 2k machine.

    Jim

  6. #6
    Linux Engineer adrenaline's Avatar
    Join Date
    Aug 2004
    Location
    Seattle, Washington
    Posts
    1,058
    Quote Originally Posted by Jimi_l

    All the XP machines login to the desktop on their own (and they work) and the 2K machine uses admin and no password. I did try making a user on the 2K machine using the same login and pass as the Linux box but it does not work.
    If you are going to log onto a network you will need a username and password. I like to keep all of the usernames and passwords the same in a mixed environment that means
    add user and pass on windows box
    add the same user and pass on linux box
    add the same user and pass on smb.
    that way when you log into your windows share it will automagically log you into the linux share.
    DO NOT EDIT the registy that is bad. put it back. It is not necessary.
    All you have to do but default to make this work is change the workgroup in the smb.conf file and add the users and restart the service and it should be working.
    read the tut that debian left above it is pretty good
    Mike
    Some people have told me they don't think a fat penguin really embodies the grace of Linux, which just tells me they have never seen a angry penguin charging at them in excess of 100mph. They'd be a lot more careful about what they say if they had.
    -- Linus Torvalds

  7. #7
    Just Joined!
    Join Date
    May 2004
    Posts
    15
    I think you may have misunderstood me. I have already done that and I have read that tutorial and several others. I am not adding multiple users on the Linux machine, they are all sharing one account.

    The Linux box, the Win2k machine and all the XP machines are all in the same workgroup and when they log into the Linux machine (and only then), they are ALL using the same login and password. This works for all the XP machines but not the 2K machine.

    What I did was make four folders on the desktop of the root account (yes I understand this is not desirable for a number of reasons). Let's call the root account-
    root
    And it's password-
    admin

    Let's call these folders-
    backup1
    backup2
    backup3
    backup4

    Using YaST I set up Samba to disable all shares on the Linux machine but these four folders. I then made the machine a member of the same workgroup that the Windows machines are on and made that workgroup trusted to share to and from.

    From the network neigbhorhood on the XP machines you can now see the Linux box and all four folders. From "My Computer" you can map drives from network sources. I browse to each users individual folder and make that folder the mapped drive for that machine. I use
    root
    For the login when asked and-
    admin
    For the password. I then click "remember on startup" and it logs in and stays logged in.

    So now user 1's mapped drive is added and labled-
    "Linux backup1"
    And so on for each machine. Using group policies I then make the network neigbhorhood vanish and only that particular folder is visable to each particular user.

    Works on all the XP machines, even all of them at once but not at all on the 2K one.

    Told you it was an odd setup. I DO plan to do it the correct way with individual users and permissions just not quite yet. Once I build the real server I will start from scratch but for now I am just getting my feet wet.

    Editing the registry is not natively "bad". It is done all the time for a variety of reasons to make changes in a Windows enviroment. I will have to respectfully disagree with you on that point.

    Thanks again for your help,

    Jim

  8. #8
    Linux Engineer adrenaline's Avatar
    Join Date
    Aug 2004
    Location
    Seattle, Washington
    Posts
    1,058
    I appreciate that fact that you respectfully dissagree with me. I didn't mean it to sound as bad as I did looking back at the caps. I just don't like to edit the registry to allow plain text passwords.

    Here lies a problem though - you should have a line in your conf file that says encrypted passwords = yes. This will work great with your XP machines. now if you enable plain text (on your 2kmachine) I don't think that will work. I am pretty sure can't do both at the same time.

    I am not sure exactly what you have going on because I have a win 2K box and a w98 box on my lan and they are networking fine. I don't network root accounts though, I wonder if you changed the name to something else as a test if that would work.

    Didn't mean any disrespect - sometimes it is hard to diagnose a network on a forum.
    Mike
    Some people have told me they don't think a fat penguin really embodies the grace of Linux, which just tells me they have never seen a angry penguin charging at them in excess of 100mph. They'd be a lot more careful about what they say if they had.
    -- Linus Torvalds

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •