Find the answer to your Linux question:
Page 2 of 3 FirstFirst 1 2 3 LastLast
Results 11 to 20 of 25
Well it was quite simple really...I used postfix though instead of sendmail as that is what SUSE uses as default... The two key things were in the mail.cf you have ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    Feb 2005
    Posts
    19

    Well it was quite simple really...I used postfix though instead of sendmail as that is what SUSE uses as default...

    The two key things were in the mail.cf

    you have to define $mydomain and $myhostname

    on inet interfaces you have to add $myhostname to the list of interfaces and that will make it listen on all IPs including the dynamic one...

    My host is called www so my MX record is also set to the www as the mailserver, not sure that is important but I did it that way to make sure it didn't mess with things...

    Only other thing I had to do in the mail.cf file was in the mydestination i added the following
    mydestination = $myhostname, localhost.$mydomain, $mydomain


    The pop3 was easy...just turn it on! LOL

    in YAST go to network services and INETD cofig...turn on the Pop3 that uses popper...don't turn on the others listed (don't know why they put them there I couldn't get them to work anyway!)

    Good luck

    OH warning....
    Suse adds it's config to the end of the Mail.cf file below the explanations of each parameter...
    Make sure you do all your work at the end of the file as Suse configures some of the things you need to add to like inet interfaces...
    I just added the $mydomain and $myhostname in there someplace before the other configs call to them....

    If you config it above where Suse does it and suse's configs overide it you'll have problems...

  2. #12
    Just Joined!
    Join Date
    Mar 2005
    Posts
    10
    Thanks for the reply,

    Do you think u can post snippets of the config files? I don't want to screw anything up

  3. #13
    Just Joined!
    Join Date
    Mar 2005
    Posts
    10
    I can't decipher the sendmail.cf?? Don't know where to define this stuff

  4. #14
    Just Joined!
    Join Date
    Mar 2005
    Posts
    10
    My mistake i forgot u are using postfix.. I'm using sendmail

  5. #15
    Just Joined!
    Join Date
    Mar 2005
    Posts
    10
    i switched to postfix, but i still can't get it???

  6. #16
    Linux Enthusiast
    Join Date
    Feb 2005
    Location
    SE, Stockholm
    Posts
    512
    mail.cf is usually located in /etc/postfix directory.
    And it is a plain text file, which also most of the installations is very good on examples inside the config file.

  7. #17
    Just Joined!
    Join Date
    Mar 2005
    Posts
    10
    I know where its at but still can't get it to work. A

  8. #18
    Linux Engineer adrenaline's Avatar
    Join Date
    Aug 2004
    Location
    Seattle, Washington
    Posts
    1,058
    Quote Originally Posted by jayfoo

    Do you think u can post snippets of the config files? I don't want to screw anything up
    Make sure you backup the cf file before you edit so if you screw up you can start over.
    cp *.cf to *.cf.bak
    then edit *.cf
    Mike
    Some people have told me they don't think a fat penguin really embodies the grace of Linux, which just tells me they have never seen a angry penguin charging at them in excess of 100mph. They'd be a lot more careful about what they say if they had.
    -- Linus Torvalds

  9. #19
    Just Joined!
    Join Date
    Mar 2005
    Posts
    10
    Ok think i have it running I unistalled sendmail.

    I can mail from my box out to my gamil account looks like this

    myname@z33.mydomain.com

    my question is how can i get so the email is just like this

    myname@mydomain.com??

  10. #20
    Just Joined!
    Join Date
    Feb 2005
    Posts
    19
    Thats where the $mydomain setting comes in...

    here is my config file...

    readme_directory = /usr/share/doc/packages/postfix/README_FILES
    biff = no
    mail_spool_directory = /var/mail
    canonical_maps = hash:/etc/postfix/canonical
    virtual_maps = hash:/etc/postfix/virtual
    relocated_maps = hash:/etc/postfix/relocated
    transport_maps = hash:/etc/postfix/transport
    sender_canonical_maps = hash:/etc/postfix/sender_canonical
    masquerade_exceptions = root
    masquerade_classes = envelope_sender, header_sender, header_recipient
    myhostname = www.microcade.com
    mydomain = microcade.com

    program_directory = /usr/lib/postfix
    inet_interfaces = $myhostname, 127.0.0.1
    masquerade_domains =
    mydestination = $myhostname, localhost.$mydomain, $mydomain
    defer_transports =
    disable_dns_lookups = no
    relayhost =
    mailbox_command =
    mailbox_transport =
    smtpd_sender_restrictions = hash:/etc/postfix/access
    smtpd_client_restrictions =
    smtpd_helo_required = no
    smtpd_helo_restrictions =
    strict_rfc821_envelopes = no
    smtpd_recipient_restrictions = permit_mynetworks,reject_unauth_destination
    smtp_sasl_auth_enable = no
    smtpd_sasl_auth_enable = no
    smtpd_use_tls = no
    smtp_use_tls = no
    alias_maps = hash:/etc/aliases
    mailbox_size_limit = 0
    message_size_limit = 10240000

    I bolded the important parts...
    your myhostname has to be the same as your MX record of the domain points to. So if your MX says www.mydomain.com your host name should also be www.mydomain.com

    I don't know what DynDNS service your using I'm using EasyDNS. there I set my primary MX to go to www.microcade.com alias, then I only register www.microcade.com via the DynDNS client (ezipupdate) and make sure to set the wildcards on it.

    You should go into yast and make sure your host name is the same as whatever your going to assign the IP to on the DNS server...
    I'm willing to bet it's currently set to z33 and you use something else to assing the IP such as www.
    I found it better to have both the same name.

    But you should be able to get what you want by just adding $mydomain to the destination parameter...and making sure you set MYdomain to just the domain not the host

Page 2 of 3 FirstFirst 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •