Find the answer to your Linux question:
Results 1 to 3 of 3
I am running Apache 2.0.52 on a Fedora core 3 box. Apache works fine, but when I restored a directory structure from another machine to the default location of /var/www/html/newdir ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2004
    Posts
    43

    Apache help


    I am running Apache 2.0.52 on a Fedora core 3 box. Apache works fine, but when I restored a directory structure from another machine to the default location of /var/www/html/newdir I am getting Forbidden, you don't have permission to access / on this server.



    The sad thing is that if I copy a file from /var/www/html/newdir to /var/www/html it works fine. If I create any additional directories in the /var/www/html directory - everything works fine there as well. There are no .htaccess files, permissions are set to drwxr-xr-x. I have tried different groups for all files, root, apache, nobody, and I keep coming up with the same error. I have no virtual directories.



    I will access the files by http://localhost/newdir... I have googled this and most people have issues with Apache itself, but Apache works fine unless I go to a subdirectory.



    Any ideas?

  2. #2
    Linux Engineer adrenaline's Avatar
    Join Date
    Aug 2004
    Location
    Seattle, Washington
    Posts
    1,058
    the document root in httpd.conf is /var/www/html you will need to change that if you want to use something else
    Some people have told me they don't think a fat penguin really embodies the grace of Linux, which just tells me they have never seen a angry penguin charging at them in excess of 100mph. They'd be a lot more careful about what they say if they had.
    -- Linus Torvalds

  3. #3
    Linux User Allblack's Avatar
    Join Date
    May 2003
    Location
    Godzone
    Posts
    416
    Do you have SELinux enabled?
    I had a hell of a time getting user directories to work until I did an install without SELinux enabled. Works all fine now. I can create whatever subfolder under /var/www/html and it works. Make sure your directory has 711 permissions and that your files are world readable.

    We are not running SELinux on our servers just yet
    I am on a journey to mastering Linux and I got a bloody long way to go!!!

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •