Find the answer to your Linux question:
Results 1 to 10 of 10
My new install of Mandrake is really giving me a hard time. I'm configuring it the way I did the first time: Code: ./configure --prefix=/usr/local/apache \ >--enable-module=all Once it installs ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux User
    Join Date
    Jun 2003
    Location
    Huntington Beach, CA
    Posts
    390

    Having problems getting the modules to install


    My new install of Mandrake is really giving me a hard time. I'm configuring it the way I did the first time:
    Code:
    ./configure --prefix=/usr/local/apache \
    >--enable-module=all
    Once it installs I go look in the apache/modules folder and theres one file! Is there something I'm doing wrong, is there something else I need to install?

  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Are you really typing exactly that? In that case, I can understand that you don't get what you want to. Remove the '>' before --enable-module=all.

  3. #3
    Linux User
    Join Date
    Jun 2003
    Location
    Huntington Beach, CA
    Posts
    390
    the > is just what the terminal shows when I use \ to skip to the next line. To be sure I tried it without using \ and still it didn't install the modules. I've also tried more than one tarbell...

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Ah, OK. Well, doesn't configure say anything about the modules? Are you sure that you actually can use --enable-module=all (ie. that you don't have to specify each module)? Although it sounds logical, I haven't seen it before.

  6. #5
    Linux User
    Join Date
    Jun 2003
    Location
    Huntington Beach, CA
    Posts
    390
    Nope still only the httpd.exp in there. This is really confusing, the modules are there in the httpd-2.0.46 folder but they wont install.

  7. #6
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Are you sure that you're compiling them as shared objects? Maybe they are compiled directly into the server. What does your entire configuration command look like?

  8. #7
    Linux User
    Join Date
    May 2003
    Location
    CA
    Posts
    370
    whats the output of
    #httpd -l -> this should show you a list of all the installed modules.
    as dolda said maybe you have directly compiled them in the server.

  9. #8
    Linux User
    Join Date
    Jun 2003
    Location
    Huntington Beach, CA
    Posts
    390
    The configure looks like this:
    Code:
    ./configure --prefix=/usr/local/apache
    I've also tried variations of --enable-module=all and still nothing. Also any time I try httpd -t or -l or -V it says command not found. Also apachectl start does nothing.

  10. #9
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Now that I look through the Apache configure script, it's pretty apparent. --enable-module does indeed build the modules into the server. To build them as DSOs, use --enables-shared=all instead.

  11. #10
    Linux User
    Join Date
    Jun 2003
    Location
    Huntington Beach, CA
    Posts
    390
    Oh man I'm such a freakin idiot. I need to do the full path name for it to work, ie /usr/local/apache/bin/httpd -t. I bet it's been working the whole time, well thanks for trying to help me with my not really problem problem anyone

    Edit: Ok quick question. For some reason it's not taking the files from the new root directory I set for it. I opened httpd.conf, made the changes to the directory root and saved it in my home directory, then as root moved it into the apache conf directory overwritting the original. After that it still was using htdocs in the /usr/local/apache directory. I removed htdocs and when I reloaded in the browser it gave me an error message. So for now im using htdocs as the root directory, but I'd like to be able to use a folder in my home directory that I can actually write to without being root. Any ideas?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •