Hi all,

When I give ps -ef | grep sendmail , I get a lot of processess running and these processess are keeping on increasing. Is this normal ? I have noticed this on any machine earlier.

ps -ef | grep sendmail

root 23941 1 0 15:37 ? 00:00:37 sendmail: accepting connections
root 23944 23941 0 15:37 ? 00:00:01 sendmail: ./h68MbYnT023944 suvi2
root 18721 23941 0 16:37 ? 00:00:01 sendmail: ./h67GkmAB028920 imweb
root 24359 23941 0 16:51 ? 00:00:00 sendmail: h68Npfnn024359 0-1pool
root 3642 23941 0 17:19 ? 00:00:00 sendmail: server joycelyn@[218.9
root 5243 23941 0 17:22 ? 00:00:00 sendmail: server vsat-148-63-139
root 7091 23941 0 17:27 ? 00:00:00 sendmail: server pe248062.user.v
root 11160 23941 0 17:33 ? 00:00:00 sendmail: server 12-245-236-217.
root 12993 23941 0 17:37 ? 00:00:01 sendmail: ./h684oQ9t002761 mail2
root 17074 23941 0 17:44 ? 00:00:00 sendmail: server host194.ara-ber
root 18583 23941 0 17:47 ? 00:00:00 sendmail: server 12-245-236-217.
root 19047 23941 0 17:48 ? 00:00:00 sendmail: server ca-lamrda-cuda1
root 19774 23941 0 17:49 ? 00:00:00 sendmail: server dsl-200-95-38-2
root 20701 23941 0 17:52 ? 00:00:00 sendmail: server dsl-200-95-38-2
root 21198 23941 0 17:53 ? 00:00:00 sendmail: server vsat-148-63-139
root 21728 23941 0 17:54 ? 00:00:00 sendmail: server pcp02580883pcs.
root 21729 23941 0 17:54 ? 00:00:00 sendmail: server pcp02580883pcs.
root 22592 23941 0 17:56 ? 00:00:00 sendmail: server 12-245-236-217.
root 22866 23941 0 17:57 ? 00:00:00 sendmail: server pcp02027639pcs.
root 23844 23941 0 18:00 ? 00:00:00 sendmail: server avcm-249.sjc.ca
root 24414 23941 0 18:01 ? 00:00:00 sendmail: server pd9505028.dip.t
root 24446 23941 0 18:01 ? 00:00:00 sendmail: server kande.com [66.1
root 24723 23941 0 18:02 ? 00:00:00 sendmail: server ns.toyotsu.ed.j
root 25278 23941 0 18:03 ? 00:00:00 sendmail: server [211.202.104.88
root 25544 23941 0 18:03 ? 00:00:00 sendmail: server [61.251.74.185]
root 26650 23941 0 18:05 ? 00:00:00 sendmail: server [66.190.180.165
root 27023 23941 0 18:06 ? 00:00:00 sendmail: server ns.toyotsu.ed.j
root 27210 23941 0 18:06 ? 00:00:00 sendmail: server host226-203.poo
root 28857 23941 0 18:09 ? 00:00:00 sendmail: server mail.askrida.co
root 29348 23941 0 18:10 ? 00:00:00 sendmail: server user162.net700.
root 30030 23941 0 18:12 ? 00:00:00 sendmail: server ppp-203.144.175
root 30116 23941 0 18:12 ? 00:00:00 sendmail: server dsl-200-95-38-2
root 30177 23941 0 18:13 ? 00:00:00 sendmail: server [63.105.150.140
root 30246 23941 0 18:13 ? 00:00:00 sendmail: server vsat-148-63-139
root 30671 23941 0 18:14 ? 00:00:00 sendmail: server [210.105.222.75
root 30953 23941 0 18:14 ? 00:00:00 sendmail: server dsl-200-67-241-
root 31036 23941 0 18:15 ? 00:00:00 sendmail: server [210.0.199.37]
root 31048 23941 0 18:15 ? 00:00:00 sendmail: h691F4nP031048 [168.18
root 31084 23941 0 18:15 ? 00:00:00 sendmail: server [66.160.64.122]
root 31096 23941 0 18:15 ? 00:00:00 sendmail: server pool-151-199-99
root 31151 23941 0 18:15 ? 00:00:00 sendmail: server [210.113.52.70]
root 31177 23941 0 18:15 ? 00:00:00 sendmail: h691FOnP031177 baits-2
root 31243 23941 0 18:15 ? 00:00:00 sendmail: h691FanP031243 [61.139
root 31258 23941 0 18:15 ? 00:00:00 sendmail: server [212.93.202.220
root 31267 23941 0 18:15 ? 00:00:00 sendmail: server cdm-66-188-15-n
root 31271 23941 0 18:15 ? 00:00:00 sendmail: server cm-66-169-87-04
root 31291 23941 0 18:15 ? 00:00:00 sendmail: server binkdings@c-67-
root 31298 23941 0 18:15 ? 00:00:00 sendmail: server 200-161-144-56.
root 31304 23941 0 18:15 ? 00:00:00 sendmail: startup with 211.114.2
root 31309 23941 0 18:15 ? 00:00:00 sendmail: server 12-218-150-238.
root 31312 1 0 18:15 ? 00:00:00 sendmail: ./h691FhnP031305 gatew
root 31315 23941 0 18:15 ? 00:00:00 sendmail: startup with 12.160.13
root 31321 23941 0 18:15 ? 00:00:00 sendmail: server [65.126.185.36]
root 31329 23941 0 18:15 ? 00:00:00 sendmail: startup with 69.42.228
root 31332 23941 2 18:15 ? 00:00:00 sendmail: server ungd@12-203-221


Please let me know if there is any fault that causes this . I tried stopping and restarting sendmail from /etc/rc.d/init.d but still lots of processess ( as mentioned above ) start. Even if I try starting it from command line using
/usr/lib/sendmail -bd -q15m
same occurs

Some users on the machine keep getting SPAM from users inside the same domain ( our domain ) .. Can this and the above problem be related ?

Thanks in advance
-K