Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
Hi guys, I've been struggling with my linux/windows/router network for a little while now and I think I'm reaching the end of a long path. One of the final hurdles ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2005
    Location
    Eastbourne, UK
    Posts
    68

    Samba Troubleshooting: Shares not available to XP client


    Hi guys, I've been struggling with my linux/windows/router network for a little while now and I think I'm reaching the end of a long path.

    One of the final hurdles though is that despite my windows client (scorpio) displaying my linux box (zen) in its workgroup (marknet), I can't access any of the shares I've set up on zen. Given that this new box is supposed to be my file/print server, this is a pretty major failing.

    I have two users of note:

    mark/pwd (my primary login for both machines)
    smbuser/pwd (a spare user for testing the samba setup)

    These have been added to the zen, scorpio and I've also used "smbpasswd -a mark" and "smbpasswd -a smbuser" to add these profiles to the samba server. The usernames and passwords are all lower case.

    Both machines have been "leased" an IP address (192.168.2.4 - zen, 192.168.2.3 - scorpio) from the belkin router which is also providing internet connectivity to both machines. Ping is successful to and from both machines.

    I've added a "public" share to the smb.conf which I am expecting to see in the network places from windows given that I log in as mark/pwd.

    I've included the global and the public share extracts from the smb.conf below.

    I can't see where I'm going wrong. The users have been set up and zen is visible to the workgroup. I just can't see any shares. Trying to explore zen results in the following message.

    "\\Zen is not accessible. You might not have permision to use this network resource. Contact the administrator of this server to find out if you have permissions. The network path was not found."

    Can anyone suggest where I'm going wrong?

    [global]
    workgroup = Marknet
    netbiosname = Zen
    printing = cups
    printcap name = cups
    printcap cache time = 750
    cups options = raw
    printer admin = @ntadmin, root, administrator
    username map = /etc/samba/smbusers
    map to guest = Bad User
    include = /etc/samba/dhcp.conf
    logon path = \\%L\profiles\.msprofile
    logon home = \\%L\%U\.9xprofile
    logon drive = P:
    security = user
    encrypt passwords = yes
    ldap idmap suffix = ou=Idmap
    ldap machine suffix = ou=Computers
    ldap suffix = dc=example,dc=com
    passdb backend = smbpasswd

    [public]
    comment = Shared documents on Zen
    path = /publicdocs
    locking = no
    security = share
    guest ok = yes
    guest account = ftp
    guest only = yes
    writeable = yes
    browseable = yes

  2. #2
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    Have you restarted samba since you added the users and shares?
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  3. #3
    Just Joined!
    Join Date
    Mar 2005
    Location
    Eastbourne, UK
    Posts
    68
    Quote Originally Posted by sarumont
    Have you restarted samba since you added the users and shares?
    Thanks for the interest. Yes, I've restarted everything. Several times. Initially, I had failed to add the users to Samba, so I could understand it not working. Now though I've added the users and rebooted both machines a couple of times. Still no improvement.

    I'm pretty shocked too. From what I've read, I believe that my XP client should be able to see the shares I've set up. But I'm missing something somewhere...

    Mark

  4. $spacer_open
    $spacer_close
  5. #4
    Linux User
    Join Date
    Feb 2005
    Posts
    290
    you have logon path and logon home specified in smb.conf + some ldap stuff .... that sounds pretty messy to me, sorry if i'm wrong

    public section, guest only = yes? hmm.....

    all right, your smb.conf is just hard for me. Perhaps you might want to try out the easiest smb.conf and see if it works. If it is, then it's time to tidy up your smb.conf :P

    backup your current smb.conf, and do the following:

    [global]
    workgroup = Marknet
    netbios name = Zen
    [test]
    comment = For testing only
    path = /tmp
    read only = no
    guest ok = yes

  6. #5
    Just Joined!
    Join Date
    Mar 2005
    Location
    Eastbourne, UK
    Posts
    68
    Quote Originally Posted by adam7979
    you have logon path and logon home specified in smb.conf + some ldap stuff .... that sounds pretty messy to me, sorry if i'm wrong
    No, don't be sorry. Thanks for the response. I'm sure it is "messy" and, most probably, wrong in some way. I'll try out your suggestion when I get home this evening. Mind you, I don't remember adding/altering logon path/home.

    Still, good advice.

    Being more comfortable with GUI managed settings, I guess I do have a tendency to let config files run away with themselves.

    Mark

  7. #6
    Just Joined!
    Join Date
    Mar 2005
    Location
    Eastbourne, UK
    Posts
    68
    Quote Originally Posted by adam7979
    ...backup your current smb.conf, and do the following:

    [global]
    workgroup = Marknet
    netbios name = Zen
    [test]
    comment = For testing only
    path = /tmp
    read only = no
    guest ok = yes
    Okay, I tried the above and Zen failed to show up in the workgroup. I added "username map" and, hey presto, Zen turned up. However, a very familiar message box popped up:

    \\Zen is not accessible. You might not have permision to use this network resource. Contact the administrator of this server to find out if you have permissions. The network path was not found.

    But this indicates to me that without the smbusers, Zen could not be shown. With it, Zen appears as the samba server knows it is allowed to advertise itself (I'm sure my terminology is terrible). So if it has authenticated, why can't it display the shares?

    Is there a log file where attempts to connect are logged? It would be good to track attempts and see how samba responds. I'll look for another thread on this or post if I can't find.

    My current smb.conf below:

    [global]
    workgroup = Marknet
    netbios name = Zen
    username map = /etc/samba/smbusers

    [test]
    comment = For testing only
    path = /tmp
    read only = no
    guest ok = yes

  8. #7
    Just Joined!
    Join Date
    Mar 2005
    Location
    Eastbourne, UK
    Posts
    68
    My log.smbd shows:

    [2005/03/16 20:24:15, 3] smbd/server.c:main(812)
    Becoming a daemon.
    [2005/03/16 20:24:15, 2] lib/tallocmsg.c:register_msg_pool_usage(57)
    Registered MSG_REQ_POOL_USAGE
    [2005/03/16 20:24:15, 2] lib/dmallocmsg.c:register_dmalloc_msgs(71)
    Registered MSG_REQ_DMALLOC_MARK and LOG_CHANGED
    [2005/03/16 20:24:16, 3] printing/printing.c:start_background_queue(1224)
    start_background_queue: Starting background LPQ thread
    [2005/03/16 20:24:16, 2] smbd/server.c:open_sockets_smbd(327)
    waiting for a connection

    It still "waits for a connection" after I try and explore Zen from windows...

    The log.nmbd is responding when windows browses the workgroup


    Oh. I just turned off my firewall... I can browse zen from windows.

  9. #8
    Just Joined!
    Join Date
    Mar 2005
    Location
    Eastbourne, UK
    Posts
    68

    Success???

    Now that I've turned off the firewall on the suse box I can browse the share.

    But through YAST I configured the firewall to allow samba... I don't get it. How can I reinstate the firewall while still allowing samba?

    I still have to log on to get to the share (a dialog is presented when trying to browse zen) but at least I can get to the simple share set up in the very simple smb.conf.

    I'm going to try some more combinations to try and get the user shares and printer.

    Mark

  10. #9
    Linux User
    Join Date
    Feb 2005
    Posts
    290
    I still have to log on to get to the share (a dialog is presented when trying to browse zen) but at least I can get to the simple share set up in the very simple smb.conf
    this is how i make my samba to show shares upon connection without asking for username/password:

    in smb.conf:
    Code:
    [global]
    guest account = guest
    and my smbusers:
    Code:
    # Unix_name = SMB_name1 SMB_name2 ...
    root = administrator admin
    nouser = guest pcguest smbguest
    good luck

  11. #10
    wlu
    wlu is offline
    Just Joined!
    Join Date
    Mar 2005
    Posts
    1

    Re: Success???

    I had the similiar problem. googling and found this article. Now I fixed mine, I like to share my experience on it. In my case, it was neither samba nor windows (not entirely) problem, more of a network config problem. Windows error message was correct for once.

    My log doesn't show anything too. so I went to support.microsoft.com to look for articles, I came across an util called nbtstat. You can use it to show chaced netbios names. so I ran "nbtstat -c" on my xp client and see

    midearth1 111.222.333.444
    midearth 192.168.0.1

    where 111.x.x.x is a fake ip for demonstration purpose. Midearth is the samba domain and midearth1 is the samba server, which is supposed to have the same ip is midearth, namely 192.168.0.1. Try it yourself, go to network neighborhood, etc, and constantly check with "nbtstat -c". the xp client will intermittenly use the external ip.

    The source of the problem is that xp client now uses DNS to reslove netbios names instead of bcast or WINS, and your samba server ip actually resloved to be a legit external ip from your dns server. I have tried setup wins server but no help. the xp client resolve the samba ip to be the external ip, and try to access it, of course, usually smb ports are blocked on your external ip. This is why you don't see any entry in your log.

    Knowing the problem, you can have many ways to fix the problem, such as
    - disable firewall to outside world on smb, which is a bad thing
    - you can take off your legit samba server dns entry (e.g. take off midearth1 and leave midearth for outside world). I think this is the preferred way, but you might still have to wait for dnslookup to timeout.
    - Setup an internal DNS server.

    I chose the latter, setup an internal dns server, be the master for my domain and 192.168.0.x, so midearth1 will always resolve to 192.168.0.1. now I just do "ipconfig /flushdns" and re-join the xp clients. everything works fine now. Happy ending.

    Hope it helps.

    Quote Originally Posted by marklawford
    Now that I've turned off the firewall on the suse box I can browse the share.

    But through YAST I configured the firewall to allow samba... I don't get it. How can I reinstate the firewall while still allowing samba?

    I still have to log on to get to the share (a dialog is presented when trying to browse zen) but at least I can get to the simple share set up in the very simple smb.conf.

    I'm going to try some more combinations to try and get the user shares and printer.

    Mark

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •