Find the answer to your Linux question:
Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 27
I have placed a .forward in a users home directory but it does not forward, I have tried /var/mail/spool/bill and bill@xxxxxxxx.com neither work Any help would be appricated Bill...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Nov 2004
    Location
    Glacier, WA
    Posts
    103

    my .forward is not working


    I have placed a .forward in a users home directory but it does not forward, I have tried
    /var/mail/spool/bill
    and
    bill@xxxxxxxx.com
    neither work

    Any help would be appricated

    Bill

  2. #2
    Linux Enthusiast
    Join Date
    Feb 2005
    Location
    SE, Stockholm
    Posts
    512
    Which mailserver are you using?
    Me my self are using Postfix, and it works like a charm without any extra parameters when I create the .forward file.

    Anyhow, in a standard configuration it is up to the local-mail-deliver process that handles this $HOME/.forward file. And in a Postfix/Sendmail system it is sendmail command that utilies this file

  3. #3
    Linux Newbie
    Join Date
    Nov 2004
    Location
    Glacier, WA
    Posts
    103

    Same here

    I am also using the Postfix/Sendmail combo on Redhat

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Enthusiast
    Join Date
    Feb 2005
    Location
    SE, Stockholm
    Posts
    512
    Strange, should work like a charm.
    However, it is not so that you have your postfix running as a special user that is not SUID?? Just to check the rights, try to decrease the security temprarly by cmod 666 .forward please, do not leave it afterwards at this, it should in fact have rw- --- --- (i.e. 600)

  6. #5
    Linux Enthusiast
    Join Date
    Feb 2005
    Location
    SE, Stockholm
    Posts
    512
    Btw, the .forward shall only be like:
    Code:
    donald.duck@duck-tales.com
    nothin more nothing less, and it wont work with directories.

  7. #6
    Linux Newbie
    Join Date
    Nov 2004
    Location
    Glacier, WA
    Posts
    103
    still no go, I even tried setting the owner to postfix

  8. #7
    Linux Enthusiast
    Join Date
    Feb 2005
    Location
    SE, Stockholm
    Posts
    512
    Really strange, hmm! What version of Postfix do you have installed at your system?
    Code:
    postconf -v | grep version
    Btw, after you have added the file, just to make sure, have you tried to restart postfix server? (You should not be needed to, but just in case)

  9. #8
    Linux Enthusiast
    Join Date
    Feb 2005
    Location
    SE, Stockholm
    Posts
    512
    While you are on to it, do this as well
    Code:
    postconf -v | grep 'forward_path'

  10. #9
    Linux Newbie
    Join Date
    Nov 2004
    Location
    Glacier, WA
    Posts
    103
    [root@glacier root]# postconf -v | grep version
    disable_mime_output_conversion = no
    mail_version = 2.0.16
    [root@glacier root]# postconf -v | grep 'forward_path'
    forward_path = $home/.forward${recipient_delimiter}${extension},$home/.forward
    [root@glacier root]#

  11. #10
    Linux Enthusiast
    Join Date
    Feb 2005
    Location
    SE, Stockholm
    Posts
    512
    Ok looks good enough!
    Hmm!
    Code:
    postconf -v| grep 'forward'
    should give you
    Code:
    allow_mail_to_commands = alias,forward
    allow_mail_to_files = alias,forward
    forward_expansion_filter = 1234567890!@%-_=+:,./abcdefghijklmnopqrstuvwxyzABCDEFGHIJKLMNOPQRSTUVWXYZ
    forward_path = $home/.forward${recipient_delimiter}${extension},$home/.forward
    prepend_delivered_header = command, file, forward
    The essential part is allow_mail_to_commands
    This is important!

Page 1 of 3 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •