Find the answer to your Linux question:
Results 1 to 4 of 4
I have been working with Apache for about 7-8 years now, and I have ran into a unique issue. The basis is that I can not get any kind of ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2005
    Posts
    2

    Apache - No error messages for failed startup???


    I have been working with Apache for about 7-8 years now, and I have ran into a unique issue. The basis is that I can not get any kind of error message to tell me where to begin. Here is the general info for everyone:

    FreeBSD 5.3
    Apache 1.3.33
    PHP 4.3.10
    Mod_ssl 2.8.22-1.3.33
    OpenSSL 0.9.7e
    Etc... etc... etc...

    Really, I just need help to get Apache to spit out an error message of why it will not start, then I think I could move on. So here are the results of startups.

    CSH
    ----------------------------------
    FreeBSD 5.3-RELEASE (GENERIC) #0: Fri Nov 5 04:19:18 UTC 2004

    % ./bin/apachectl configtest
    Syntax OK
    % ./bin/apachectl startssl
    ./bin/apachectl startssl: httpd could not be started
    % ./bin/apachectl start
    ./bin/apachectl start: httpd started
    % ./bin/apachectl stop
    ./bin/apachectl stop: httpd stopped

    ----------------------------------

    As you can see, the server starts well without the startssl switch. Anyone have ideas on how I can force some error out of Apache or track down an error (startup error log) to start debugging the problem?

    Thanks in advance for your time,

    Tait

  2. #2
    Linux Enthusiast
    Join Date
    Feb 2005
    Location
    SE, Stockholm
    Posts
    512
    Hi, I had a similar issue when Apache was not able to reach the certificate files. I'm sure you have already done this, but just do an extra check of the rights to certificate files. And that you have not misspelled them in you apache config file(s). I have seen that "mod_ssl" is not to much of logger, and as in your case here, there will not be to much of help from it either

  3. #3
    Just Joined!
    Join Date
    Mar 2005
    Posts
    2

    Got it

    Thanks for the help! I checked out the VHOSTS and all was well, so working into trouble shooting and reading what you were mentioning - I tried rebuilding the certificate from OpenSSL (versus 'make certificate TYPE=custom). It seamed to work great.

    So if anyone else gets the same error that I had then try this to see if this works for you:

    ----------------------------------------------------

    #!/bin/csh

    mkdir /usr/local/apache/conf/ssl.pem/

    cd /usr/local/apache/
    openssl req -new > server.csr
    openssl rsa -in privkey.pem -out server.key
    openssl x509 -in server.csr -out server.crt -req -signkey server.key -days 365

    mv server.crt /usr/local/apache/conf/ssl.crt/
    mv server.key /usr/local/apache/conf/ssl.key/
    mv privkey.pem /usr/local/apache/conf/ssl.pem/

    /usr/local/apache/bin/apachectl stop
    /usr/local/apache/bin/apachectl startssl

    ----------------------------------------------------

    Thanks again,

    -- T

    :rock:

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Feb 2009
    Posts
    1

    Check RewriteLog path

    I realize this is a 4-year-old conversation. Nonetheless...

    I had a similar situation--no message and service httpd restart [FAILED]--after copying some lines from one machine to another. I found the problem was the path specified for a RewriteLog in one of the VirtualHost entries. The path did not exist on the target server.

    I only found the problem after commenting out sections of the pasted in code (put # in the first character of each line). Commented out a section, tried to restart, repeat.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •