Find the answer to your Linux question:
Results 1 to 5 of 5
HI Guys; I tested my linux 9 DNS server from xp clients by nslookup. It is not show following message. Default Server domainname) Address Dns IP) It is show me ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Try
    Try is offline
    Just Joined!
    Join Date
    Mar 2005
    Posts
    7

    nslookup


    HI Guys;


    I tested my linux 9 DNS server from xp clients by nslookup.

    It is not show following message.

    Default Server domainname)
    Address Dns IP)

    It is show me following message

    Default Server :unknow
    Address :IP

    So I checked my web server and DNS server.They are running.

    How to solve this problem .Please explain me Dear Guys............

  2. #2
    Linux Enthusiast
    Join Date
    Feb 2005
    Location
    SE, Stockholm
    Posts
    512
    This is most probably due to the fact that you have nt configured anything else than the standard configuration if your BIND server.
    You need at least to have a fake domain to get rid of this message.
    However, it is not necessary to have a domain configured for your usage of a close/near DNS service.

  3. #3
    Try
    Try is offline
    Just Joined!
    Join Date
    Mar 2005
    Posts
    7

    Instruction me

    Quote Originally Posted by swemic
    This is most probably due to the fact that you have nt configured anything else than the standard configuration if your BIND server.
    You need at least to have a fake domain to get rid of this message.
    However, it is not necessary to have a domain configured for your usage of a close/near DNS service.
    Dear swemic

    Can you instruction me dns configuration me for this problem.

  4. #4
    Linux Enthusiast
    Join Date
    Feb 2005
    Location
    SE, Stockholm
    Posts
    512
    First of all you'll need a file /etc/named.conf
    Which could look like something like this
    Code:
    options {
            pid-file "/var/run/named/named.pid";
            directory "/var/named";
    };
    
    zone "." {
            type hint;
            file "named.ca";
    };
    
    zone "0.0.127.in-addr.arpa" {
            type master;
            file "named.local";
    };
    
    zone "myinternal.priv" {
            type master;
            file "/var/named/myinternal.hosts";
    };
    This will give you a Zone for domain myinternal.priv

    Next thing is to create the file /var/named/myinternal.hosts
    which should/could look like something like this:
    Code:
    myinternal.priv           IN SOA  ns.myinternal.priv. postmaster.myinternal.priv. (
                                    2005032301 ; serial
                                    28800      ; refresh (8 hours)
                                    14400      ; retry (4 hours)
                                    360000     ; expire (4 days 4 hours)
                                    86400      ; minimum (1 day)
                                    )
                            NS      ns.myinternal.priv.
    
    ns                A        <ip-of-your-dns-server>
    You should change all values from above example to fit your enviroment.
    That is the IP of the ns A record, your domain has to be equal to your internal domain, otherwise you will get errors like you did previous.

    But as I said before, it is not necessary to have a SOA record of your own, to have a cache-only DNS server.

  5. #5
    Try
    Try is offline
    Just Joined!
    Join Date
    Mar 2005
    Posts
    7

    vpn

    Dear swemic;

    help me.please read the following link.

    http://www.linuxforums.org/forum/topic-37953.html

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •