Find the answer to your Linux question:
Page 3 of 4 FirstFirst 1 2 3 4 LastLast
Results 21 to 30 of 34
Oh, when you have done this, there is no need to run the compilation. All you have to do is to start the Squid service. And from a shell as ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #21
    Linux Enthusiast
    Join Date
    Feb 2005
    Location
    SE, Stockholm
    Posts
    512

    Oh, when you have done this, there is no need to run the compilation.
    All you have to do is to start the Squid service.
    And from a shell as root
    Code:
    /etc/init.d/squid start
    However you can set this up to start automaticaly by get into the Mandrake Control Center - > System -> Services.
    Just make sure "On boot" is marked for Squid service. Then you are up'n'running

  2. #22
    Just Joined!
    Join Date
    Mar 2005
    Posts
    58
    Wouldn't ya know there's another problem? lol

    There isn't a "squid" in the /etc/init.d/ directory.

  3. #23
    Linux Enthusiast
    Join Date
    Feb 2005
    Location
    SE, Stockholm
    Posts
    512
    And after you did "urpmi squid" you did not get any error messages?
    This is somewhat strange

  4. #24
    Just Joined!
    Join Date
    Mar 2005
    Posts
    58
    I don't believe so. Would it hurt anything for me to re-run that command?

  5. #25
    Just Joined!
    Join Date
    Mar 2005
    Posts
    58
    I reran the "urpmi squid", and it is giving me an error message. I don't remember getting an error yesterday. Anyways, I'm getting:

    The following packages have bad signatures:
    /var/cache/urpmi/rpms/squid-2.5.STABLE6-2.4.101mdk.i586.rpm: Invalid signature ((SHA1) DSA shal md5 (GPG) (MISSING KEY) GPG#22458a98 NOT OK)
    Do you want to continue installation? (y/N)

  6. #26
    Linux Enthusiast
    Join Date
    Feb 2005
    Location
    SE, Stockholm
    Posts
    512
    Ahh! There you go, I beleive that you did not install the Squid anyhow.
    Well, with a bunch of hair on you chest, say Y there and the Squid will be installed. I dont know why sometimes the md5-key verification is not included. I suspect it has to do with the Contrib files more or less. Anyhow, I would in this case trust the file with or without the MD5 signature.

  7. #27
    Just Joined!
    Join Date
    Mar 2005
    Posts
    58
    Progress!

    In Webmin, when I attempt to initialize the cache, I get:

    Initializing the Squid cache with the command squid -f /etc/squid/etc/squid.conf -z ..

    FATAL: Could not determine fully qualified hostname. Please set 'visible_hostname'

    Squid Cache (Version 2.5.STABLE6): Terminated abnormally.
    CPU Usage: 0.015 seconds = 0.007 user + 0.008 sys
    Maximum Resident Size: 0 KB
    Page faults with physical i/o: 0

    Where do I set a hostname? Can this be done through Webmin, or is it just in the squid.conf? (Man, I really am sorry that I'm ignorant about this stuff)

  8. #28
    Linux Enthusiast
    Join Date
    Feb 2005
    Location
    SE, Stockholm
    Posts
    512
    ok, you have to change a few settings in Webmin to fit your environment,
    first of all you have to change the path to your squid.conf from /etc/squid/etc/squid.conf into /etc/squid/squid.conf

    You might need to tell webmin where the binary "squid" is as well. But well start here

  9. #29
    Just Joined!
    Join Date
    Mar 2005
    Posts
    58
    Okay, got that done.

  10. #30
    Linux Enthusiast
    Join Date
    Feb 2005
    Location
    SE, Stockholm
    Posts
    512
    Could you initialize the squid database now?
    If so, youre up'n'running.
    You should be able to set you browser to use proxy,
    and the settings should be <ip-of-you-proxy-server> and port 3128
    Oh, yeah, not to forgett, issu command
    Code:
    /etc/init.d/squid start
    before you try your proxy as well

Page 3 of 4 FirstFirst 1 2 3 4 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •