Find the answer to your Linux question:
Results 1 to 3 of 3
hi i'm new to linux, i'm running debian sarge.. .i installed apache, and got it working, but i was editing the /etc/init.d/apache2 file, and i accidentally saved it, and now ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2005
    Posts
    2

    apache2 problem


    hi

    i'm new to linux, i'm running debian sarge.. .i installed apache, and got it working, but i was editing the /etc/init.d/apache2 file, and i accidentally saved it, and now i can't start up apache. i tried apt-get install apache2 --reinstall, but that doesn't work. i also tried removing apache 2 (apt-get remove apache2) and then installing (apt-get install apache2), and i tried removing the /etc/init.d/apache2 file, and then reinstalling, but even after a reinstall, the /etc/init.d/apache2 file isn't there .

    what can i do

  2. #2
    Linux Newbie
    Join Date
    Dec 2004
    Location
    Barrie, Ontario
    Posts
    219
    I just checked the Debian package repository and it shows that script as being part of apache2-common (third from the bottom), so try reinstalling that package.
    Blog - KB5UMQ - Linux User #272983
    3 Rules:
    1) "It doesn't work..." is simply not useful information.
    2) Don't cross post!
    3) If you are asking for help, start by telling us your distro/os and version.

  3. #3
    Linux Newbie
    Join Date
    Sep 2003
    Location
    St.Charles, Missouri, USA
    Posts
    201
    Code:
     apache2 -k start
    should work too
    Powered by Gentoo
    never ever ever use the hardened option in make.conf!

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •