Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    BIND and DNS issues


    I'm trying to set up DNS for my site I registered the two DNS servers with my registrar as pointing to and pointing to

    Anyways, even when I ping the domain when I have my DNS server set to the server, I get no response. Here is how I have the named file configured:

    zone "." {
    type hint;
    file "named.root";

    zone "0.0.127.IN-ADDR.ARPA" {
    type master;
    file "localhost.rev";

    zone "" {
    type master;
    file "";
    allow-transfer {;

    zone "" {
    type slave;
    file "s/";
    masters {;

    And the zone file:

    $TTL 86400
    @ IN SOA (
    2005032400 ;serial
    28800 ;refresh
    14400 ;retry delay
    86400 ;expire
    21600 ;default_ttl

    @ IN NS
    IN NS

    @ IN A

    www IN A
    ns IN A
    ns2 IN A

    Where am I going wrong here? Do I have to wait longer for the DNS to propagate? Surely if I point my machine to the server I shouldn't have to...

    Any help is appreciated.

  2. #2
    Well let's take an outside perspective.


    DNS Crawler tried each of your dns servers, but got a "lame" response from each. Basically your dns server doesn't know it is a host for the domain "".

    Now, I don't know what your distro is, so I can't determine where your named.conf is located for sure, or if you're using chroot, so I'll just make a best guess. Show me the response for this command on

    named-checkconf -zj /etc/named.conf

  3. #3
    Thanks for your help.
    Here's what I got.

    [root@alexandrerochedesign root]# named-checkconf -zj /etc/named.conf
    named-checkconf: illegal option -- z
    usage: named-checkconf [-v] [-t directory] [named.conf]

    So then I tried these commands:

    [root@alexandrerochedesign root]# named-checkconf named.conf
    none:0: open: named.conf: file not found

    [root@alexandrerochedesign root]# named-checkconf /etc/named.conf
    /etc/named.conf:108: zone '': already exists

    Any ideas?

  4. $spacer_open
  5. #4
    I guess BIND 9.2.1 named-checkconf doesn't support the z option. Pity. BIND 9.3 does.

    I took a second look at your named.conf pasting. Just noticed you've got the same zone twice. You don't want to define a master and a slave for the same zone in the same config. Remove the slave zone {} block and "rndc reload", then check my DNS Crawler link again.

  6. #5
    Seemed to work.

    No answer records but gave the authority records as and

  7. #6
    But when I ping the domain from the server it still doesn't work.

    Also, how do I set up the secondary on the same server then? Or do I need to with the way I have it listed in the zone file?


  8. #7
    There must be something wrong with my zone file....
    Or maybe the cache/boot/reverse and forward mapping files?
    I haven't touched those files at all.... I assume that I don't need to, right?

    Again, thanks for your help, I'm new to this.

  9. #8
    The DNS Crawler link is still calling both of your name servers "lame servers". This is not a good thing. So let's see the fruits of your labor by showing me the results for this command again:

    named-checkconf /etc/named.conf

    Also, I want to see if your BIND is chroot'd. Show me the results for this command:

    ps -Af | grep 'named'

    You do not need to setup a secondary. Both of your name servers are the same server, so there is only 1 master server.

  10. #9
    For the first one it gave me no results.... which I assume is a good thing. It just jumped to the next line in the terminal.

    [root@alexandrerochedesign root]# named-checkconf /etc/named.conf

    Here's what it gave me for the second one:

    [root@alexandrerochedesign root]# ps -Af | grep 'named'
    named 16387 1 0 11:56 ? 00:00:00 /usr/sbin/named -u named -n1 -c /etc/named.conf -u named -t /var/named/run-root
    root 32003 6310 0 12:16 pts/1 00:00:00 grep named

    Thanks again....

  11. #10
    Yep, it's chroot'd so that complicates things. Let's see the results of this command instead:

    named-checkconf -t /var/named/run-root /etc/named.conf

    I also want to see the results of this command: (make sure it's symlink'd)

    ls -l /etc/named.conf

    And this command: (make sure it exists)

    ls -l /var/named/run-root/etc/named.conf

    And this command: (check syntax and existance)

    named-checkzone /var/named/run-root/var/named/

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts