Find the answer to your Linux question:
Page 2 of 4 FirstFirst 1 2 3 4 LastLast
Results 11 to 20 of 40
for google.com ; <<>> DiG 9.2.2-P3 <<>> www.google.com ;; global options: printcmd ;; connection timed out; no servers could be reached for google.org ;; Warning: ID mismatch: expected ID 2651, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    Mar 2005
    Posts
    21

    output


    for google.com

    ; <<>> DiG 9.2.2-P3 <<>> www.google.com
    ;; global options: printcmd
    ;; connection timed out; no servers could be reached

    for google.org

    ;; Warning: ID mismatch: expected ID 2651, got 9918
    ;; Warning: ID mismatch: expected ID 2651, got 9918

    ; <<>> DiG 9.2.2-P3 <<>> www.google.org
    ;; global options: printcmd
    ;; connection timed out; no servers could be reached


  2. #12
    Linux Newbie
    Join Date
    Mar 2005
    Posts
    230
    Are you running iptables?

    Let's see if a request even makes it out, and a response makes it back.

    dig @216.239.32.10 google.com

    Let's see if BIND was able to cache anything in the google query:

    dig +norec google.com any

  3. #13
    Just Joined!
    Join Date
    Mar 2005
    Posts
    21
    dig @216.239.32.10 google.com

    ; <<>> DiG 9.2.2-P3 <<>> @216.239.32.10 google.com
    ;; global options: printcmd
    ;; connection timed out; no servers could be reached


    dig +norec google.com any

    ; <<>> DiG 9.2.2-P3 <<>> +norec google.com any
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 47804
    ;; flags: qr ra; QUERY: 1, ANSWER: 0, AUTHORITY: 13, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;google.com. IN ANY

    ;; AUTHORITY SECTION:
    . 3600000 IN NS B.ROOT-SERVERS.NET.
    . 3600000 IN NS C.ROOT-SERVERS.NET.
    . 3600000 IN NS D.ROOT-SERVERS.NET.
    . 3600000 IN NS E.ROOT-SERVERS.NET.
    . 3600000 IN NS F.ROOT-SERVERS.NET.
    . 3600000 IN NS G.ROOT-SERVERS.NET.
    . 3600000 IN NS H.ROOT-SERVERS.NET.
    . 3600000 IN NS I.ROOT-SERVERS.NET.
    . 3600000 IN NS J.ROOT-SERVERS.NET.
    . 3600000 IN NS K.ROOT-SERVERS.NET.
    . 3600000 IN NS L.ROOT-SERVERS.NET.
    . 3600000 IN NS M.ROOT-SERVERS.NET.
    . 3600000 IN NS A.ROOT-SERVERS.NET.

    ;; Query time: 71 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Sun Apr 3 03:41:31 2005
    ;; MSG SIZE rcvd: 239

    how do i check wether im using iptables or not????

  4. #14
    Linux Newbie
    Join Date
    Mar 2005
    Posts
    230
    Try these commands:

    service iptables stop
    dig +tcp @216.239.32.10 google.com
    ping 216.239.32.10

  5. #15
    Linux Newbie
    Join Date
    Dec 2004
    Location
    Barrie, Ontario
    Posts
    219
    Take a step back...

    In your resolv.conf you have:
    Code:
    nameserver 127.0.0.1
    which means that your machine is acting as the nameserver for your machine. No wonder you can't resolve anything...

    For a test, use two of my nameservers in your resolv.conf:
    Code:
    nameserver 209.226.39.19
    nameserver 209.226.39.18
    then restart your networking:
    Code:
    /etc/init.d/network restart
    then try to ping google or yahoo:
    Code:
    ping www.google.com
    ping www.yahoo.com
    and see what you get...

    If you can resolve names using my nameservers, then you just need to change your nameservers to be those of your ISP and you should be fixed.
    Blog - KB5UMQ - Linux User #272983
    3 Rules:
    1) "It doesn't work..." is simply not useful information.
    2) Don't cross post!
    3) If you are asking for help, start by telling us your distro/os and version.

  6. #16
    Linux Newbie
    Join Date
    Mar 2005
    Posts
    230
    The guy can't even send a request to google's name server and get a response. I have doubts that his internet is even working.

    And it may be preferred that he uses BIND to resolve stuff, cause having a local, flushable, cache is faster and more convenient than using offsite dns servers. Shoot, I run BIND on my windows machine rather than use Microsoft's DNS Client service. The guy wants his BIND fixed, and that's what I'm helping him do. It is very common that BIND acts as a name server for the local machine.

  7. #17
    Just Joined!
    Join Date
    Mar 2005
    Posts
    21

    dig.....

    [root@localhost root]# dig +tcp @216.239.32.10 google.com
    ;; Connection to 216.239.32.10#53(216.239.32.10) for google.com failed: network unreachable.


    [root@localhost root]# ping 216.239.32.10
    connect: Network is unreachable

    My internet is working just fine....I tried what 'Kode' has written but it is also not working....

  8. #18
    Linux Newbie
    Join Date
    Mar 2005
    Posts
    230
    Course it isn't. He's just guessing, but I've had you give me a lot of information which helps figure out the problem without guessing. Now make sure your resolv.conf is back to the original "nameserver 127.0.0.1" and nothing else. Your internet might be just fine, but your internet related configuration on your linux machine sure isn't. "network unreachable" is not a good thing when pinging an IP address. DNS wasn't even involved there.

    So we move into network configuration. Show me the results of the following commands:

    route
    ifconfig

  9. #19
    Just Joined!
    Join Date
    Mar 2005
    Posts
    21
    route

    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use Iface
    192.168.0.0 * 255.255.255.0 U 0 0 0 eth0
    169.254.0.0 * 255.255.0.0 U 0 0 0 eth0
    127.0.0.0 * 255.0.0.0 U 0 0 0 lo


    ifconfig

    eth0 Link encap:Ethernet HWaddr 00:A1:B0:10:9C:48
    inet addr:192.168.0.30 Bcast:192.168.0.255 Mask:255.255.255.0
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:3385 errors:0 dropped:0 overruns:0 frame:0
    TX packets:3997 errors:6 dropped:0 overruns:0 carrier:0
    collisions:760 txqueuelen:1000
    RX bytes:1300553 (1.2 Mb) TX bytes:641796 (626.7 Kb)
    Interrupt:10 Base address:0xb800

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:1529 errors:0 dropped:0 overruns:0 frame:0
    TX packets:1529 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:1124876 (1.0 Mb) TX bytes:1124876 (1.0 Mb)

  10. #20
    Linux Newbie
    Join Date
    Mar 2005
    Posts
    230
    You need to setup a default gateway. That would explain the "Network unreachable" errors. Now, I'm no networking genius, but I believe the following command will fix that real quick.

    route add default gw 192.168.0.1

    Once you do that, execute this command:

    ping 216.239.32.10

    If you got a network unreachable again, I want to see the results for this command:

    route

    If you actually got ping replies, then tell me how everything else is working.

Page 2 of 4 FirstFirst 1 2 3 4 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •