Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
Code: Starting sendmail: makemap: error opening type hash map /etc/mail/virtusertable: Permission denied makemap: error opening type hash map /etc/mail/access: Executable files not allo wed makemap: error opening type hash map ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux User
    Join Date
    May 2003
    Location
    Hong Kong, China
    Posts
    256

    Urgent help! makemap error!!!


    Code:
    Starting sendmail: makemap: error opening type hash map /etc/mail/virtusertable:
     Permission denied
    makemap: error opening type hash map /etc/mail/access: Executable files not allo
    wed
    makemap: error opening type hash map /etc/mail/domaintable: Permission denied
    makemap: error opening type hash map /etc/mail/mailertable: Permission denied
    and how do I config sendmail to send out via router to the outside network???????????
    how do people send in e-mail from outside my network???


    Signature removed by moderator - please see forum rules

  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Become root, go to /etc/mail and run "make". That should rebuild all maps in the name of root.

  3. #3
    Linux User
    Join Date
    May 2003
    Location
    Hong Kong, China
    Posts
    256
    make
    make: Nothing to be done for `all'.
    Signature removed by moderator - please see forum rules

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Hmm... OK, then, run "make clean && make", then try to restart sendmail.

  6. #5
    Linux User
    Join Date
    May 2003
    Location
    Hong Kong, China
    Posts
    256
    Okie, thanks mate, sigh, just arrived at office, can not try it......................
    Signature removed by moderator - please see forum rules

  7. #6
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Really? Can't you just putty home?

  8. #7
    Linux User
    Join Date
    May 2003
    Location
    Hong Kong, China
    Posts
    256
    no ftp is allowed here in my office ah! so dumb! the firewall here blocks it! I am an hour away from my home!
    Signature removed by moderator - please see forum rules

  9. #8
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Putty isn't FTP; it's SSH. Have they blocked SSH as well?

  10. #9
    Linux User
    Join Date
    May 2003
    Location
    Hong Kong, China
    Posts
    256
    I have always been told that some services must be disabled if are not needed by me to prevent intrusions. I dunno about ssh, I think my company blocks anything that is not http's. even any word related to web mail is censored by the firewall when i type the http address in web browser. strict as hell. this a bank, so..................


    thanks

    regards
    Signature removed by moderator - please see forum rules

  11. #10
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Oh... too bad.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •