Find the answer to your Linux question:
Results 1 to 3 of 3
okay, so since I was not able to get into the database mysql anymore (story on my previous post) my dumb ass decided to try deleting it and recreat it ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2003
    Posts
    50

    completely scr*wed now - please help


    okay, so since I was not able to get into the database mysql anymore (story on my previous post) my dumb ass decided to try deleting it and recreat it with mysql_install_db. Well, that didn't work. So, my stupid ass decided go download it again and just run the install and hoping it would just replace the missing files... well, I didn't realize the version I downloaded is just a tiny bit different... my system is running version 3.23.56 and I downloaded 3.23.57 Anyways, I ran the rpm to install the package. What happenned? I got file conflicts, thats when I realized my new downloaded package is a different version. What did my stupid dumb ass do? I go manually delete all the conflicted files. Ran the rpm install again and noooo it didn't work. I still got the same file conflicts! But the funny thing is the files do not exist anymore. How can that be??? I think I totally screwed. My original install was from redhat 9 by the way. I tried using the add/remove programs in redhat... but that didn't work either, tell me missing files.... the ones I deleted from mysql folder.... so can somebody help my padawan ass??? Please tell me there is a way to force the installation or manually completely remove the old mysql package so i can just reinstall it.

  2. #2
    Linux Engineer
    Join Date
    Jan 2003
    Location
    Lebanon, pa
    Posts
    994
    Download the rpm of your prvious version and run this:
    rpm -Uvh --replacepkgs somefile.rpm

  3. #3
    Just Joined!
    Join Date
    Jun 2003
    Posts
    50
    that worked! you are da man! I had to run the mysql_install_db and then delete the mysql.socket thing. restart the system for good measure and everything works now. thank you so much. no regrets... i actually learned alot from this problem.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •