Find the answer to your Linux question:
Results 1 to 7 of 7
Hello, First to say that I'm new with linux! I have Fedora3 and have problem with vsftpd. I have started vsftpd like standalone, and everything is working nice except downloads. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2005
    Posts
    5

    vsftpd problems with download


    Hello,
    First to say that I'm new with linux!
    I have Fedora3 and have problem with vsftpd.
    I have started vsftpd like standalone, and everything is working nice except downloads. I can connect, I can upload files, I can delete files on ftp server but only thing that I CAN'T do is do download filoes from vsftpd.
    I have tried a lot of options, disable iptable service and so on, but when I start to download file it stops and timeout after some time!
    here You can see one example of my problem:
    Any help?! PLEASE

    230 Login successful.
    ftp> ls
    200 PORT command successful. Consider using PASV.
    150 Here comes the directory listing.
    spybotsd13.exe
    226 Directory send OK.
    ftp: 23 bytes received in 0,00Seconds 23000,00Kbytes/sec.
    ftp> mget sp*
    200 Switching to ASCII mode.
    mget spybotsd13.exe?
    200 PORT command successful. Consider using PASV.
    150 Opening BINARY mode data connection for spybotsd13.exe (4354084 bytes)

  2. #2
    Linux Enthusiast
    Join Date
    Feb 2005
    Location
    SE, Stockholm
    Posts
    512
    First of all, you do get some strange mode, you should be in BINARY mode when you download anything except text-files. So try to issue command "bin" prior your download.
    Second, and last, try to choose Passive mode as proposed from the ftp-server reply 200. That is done by command "pasv" if you are NOT on Windows.

  3. #3
    Just Joined!
    Join Date
    May 2005
    Posts
    5

    still don't working!

    Thanks for reply!
    I'm testing download from windows PC and I have try to use binary download but nothing! I have try also with WS_ftp pro but it's same, I can connect, upload and delete files but not to download.
    Also when I start to download somw file with WS_ftp pro, download starts but speed is 0,08KBps and both PC-s are on local LAN (vsftp server and second PC). Also I have to say that I have new installation of FC3 and I have tryed with default configuration file but... again I have same problem! Also I have trzed with proftpd server but it's same.
    Here is vsftp.conf file maybe this will help:
    # Example config file /etc/vsftpd/vsftpd.conf
    #
    # The default compiled in settings are fairly
    paranoid. This sample file
    # loosens things up a bit, to make the ftp daemon more
    usable.
    # Please see vsftpd.conf.5 for all compiled in
    defaults.
    #
    # READ THIS: This example file is NOT an exhaustive
    list of vsftpd options.
    # Please read the vsftpd.conf.5 manual page to get a
    full idea of vsftpd's
    # capabilities.
    #
    # Allow anonymous FTP? (Beware - allowed by default if
    you comment this out).
    anonymous_enable=NO
    #
    # Uncomment this to allow local users to log in.
    local_enable=YES
    #
    # Uncomment this to enable any form of FTP write
    command.
    write_enable=YES
    #
    # Default umask for local users is 077. You may wish
    to change this to 022,
    # if your users expect that (022 is used by most other
    ftpd's)
    local_umask=022
    #
    # Uncomment this to allow the anonymous FTP user to
    upload files. This only
    # has an effect if the above global write enable is
    activated. Also, you will
    # obviously need to create a directory writable by the
    FTP user.
    #anon_upload_enable=YES
    #
    # Uncomment this if you want the anonymous FTP user to
    be able to create
    # new directories.
    #anon_mkdir_write_enable=YES
    #
    # Activate directory messages - messages given to
    remote users when they
    # go into a certain directory.
    dirmessage_enable=YES
    #
    # Activate logging of uploads/downloads.
    xferlog_enable=YES
    #
    # Make sure PORT transfer connections originate from
    port 20 (ftp-data).
    connect_from_port_20=YES
    #
    # If you want, you can arrange for uploaded anonymous
    files to be owned by
    # a different user. Note! Using "root" for uploaded
    files is not
    # recommended!
    #chown_uploads=YES
    #chown_username=whoever
    #
    # You may override where the log file goes if you
    like. The default is shown
    # below.
    xferlog_file=/var/log/vsftpd.log
    #
    # If you want, you can have your log file in standard
    ftpd xferlog format
    xferlog_std_format=YES
    #
    # You may change the default value for timing out an
    idle session.
    #idle_session_timeout=600
    #
    # You may change the default value for timing out a
    data connection.
    #data_connection_timeout=120
    #
    # It is recommended that you define on your system a
    unique user which the
    # ftp server can use as a totally isolated and
    unprivileged user.
    #nopriv_user=ftpsecure
    #
    # Enable this and the server will recognise
    asynchronous ABOR requests. Not
    # recommended for security (the code is non-trivial).
    Not enabling it,
    # however, may confuse older FTP clients.
    async_abor_enable=YES
    #
    # By default the server will pretend to allow ASCII
    mode but in fact ignore
    # the request. Turn on the below options to have the
    server actually do ASCII
    # mangling on files when in ASCII mode.
    # Beware that turning on ascii_download_enable enables
    malicious remote parties
    # to consume your I/O resources, by issuing the
    command "SIZE /big/file" in
    # ASCII mode.
    # These ASCII options are split into upload and
    download because you may wish
    # to enable ASCII uploads (to prevent uploaded scripts
    etc. from breaking),
    # without the DoS risk of SIZE and ASCII downloads.
    ASCII mangling should be
    # on the client anyway..
    ascii_upload_enable=YES
    ascii_download_enable=YES
    #
    # You may fully customise the login banner string:
    ftpd_banner=Welcome to FTP
    service.Warning! All Your activity will be logged!
    #
    # You may specify a file of disallowed anonymous
    e-mail addresses. Apparently
    # useful for combatting certain DoS attacks.
    #deny_email_enable=YES
    # (default follows)
    #banned_email_file=/etc/vsftpd.banned_emails
    #
    # You may specify an explicit list of local users to
    chroot() to their home
    # directory. If chroot_local_user is YES, then this
    list becomes a list of
    # users to NOT chroot().
    #chroot_list_enable=YES
    # (default follows)
    #chroot_list_file=/etc/vsftpd.chroot_list
    #
    # You may activate the "-R" option to the builtin ls.
    This is disabled by
    # default to avoid remote users being able to cause
    excessive I/O on large
    # sites. However, some broken FTP clients such as
    "ncftp" and "mirror" assume
    # the presence of the "-R" option, so there is a
    strong case for enabling it.
    #ls_recurse_enable=YES

    pam_service_name=vsftpd
    userlist_enable=YES
    #enable for standalone mode
    listen=YES
    tcp_wrappers=YES

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Enthusiast
    Join Date
    Feb 2005
    Location
    SE, Stockholm
    Posts
    512
    Ok! Did you try to force Passive Mode as well? If not, try that, can't remember exactly where in WS_FtpPRO you do set this up, but it should be somewhere in your connection configuration

  6. #5
    Just Joined!
    Join Date
    May 2005
    Posts
    5

    no changes again!

    tryed in PASV but it's same!

  7. #6
    Just Joined!
    Join Date
    Apr 2005
    Posts
    40
    Well, try this:

    async_abor_enable=NO
    ascii_upload_enable=NO
    ascii_download_enable=NO


    Then you should lock your users in their home dirs:

    chroot_list_enable=YES
    chroot_list_file=/etc/vsftpd.chroot_list #Or some other file


    And it should be wiser to run ftp server from inetd or xinetd...


    I guess this is enabled by default but try this yet:

    pasv_enable=YES

  8. #7
    Just Joined!
    Join Date
    May 2005
    Posts
    5

    PROBLEM SOLVED :)

    THANKS FOR SUPPORT TO EVERYONE!!!
    Bulieve it or not problem was with network card, it was RTL8139B and after I have replace it with 3Com 905B everything was OK.
    One more time thanks! :P

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •