Find the answer to your Linux question:
Results 1 to 3 of 3
Hey guys and girls. I just have a small issue i am tring to work thought. I have setup a pc at work and running it as a little file ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2005
    Posts
    1

    Samba Public Share Problem


    Hey guys and girls.

    I just have a small issue i am tring to work thought. I have setup a pc at work and running it as a little file server. However i am having trouble getting to it without needing to authenticate myself.

    When i authenticae myself its all cool but i would like a guest account to default be able to access one share.

    the computer im connecting it to from is part of a domain and the samba server is just a standalone machine.

    Could anyone give me any suggestions as to what i can do so i don't need to authenticate myself to access this share

    I have a dump of my SMB.conf file. Im running slackware 10

    [global]


    workgroup = MYGROUP

    server string = Dumpty Dum

    security = user

    ; hosts allow = 192.168.5.108 127.

    # Uncomment this if you want a guest account, you must add this to /etc/passwd
    # otherwise the user "nobody" is used
    guest account = nobody

    log file = /var/log/samba.%m

    # Put a capping on the size of the log files (in Kb).
    max log size = 50

    # Most people will find that this option gives better performance.
    # See the chapter 'Samba performance issues' in the Samba HOWTO Collection
    # and the manual pages for details.
    # You may want to add the following on a Linux system:
    # SO_RCVBUF=8192 SO_SNDBUF=8192
    socket options = TCP_NODELAY

    add user script = /usr/sbin/useradd %u
    add group script = /usr/sbin/groupadd %g
    add machine script = /usr/sbin/adduser -n -g machines -c Machine -d /dev/null -s /bin/false %u
    delete user script = /usr/sbin/userdel %u
    delete user from group script = /usr/sbin/deluser %u %g
    delete group script = /usr/sbin/groupdel %g


    #============================ Share Definitions ==============================
    [homes]
    comment = Home Directories
    browseable = no
    writable = yes

    # This one is useful for people to share files
    [tmp]
    comment = Temporary file space
    path = /home/tmp
    read only = no
    public = yes
    force user = nobody

    # My Stuff
    [Little Dump]
    comment = Dumpty Dum
    public = yes
    path = /home/ftp
    write list = ben
    writable = yes




    Any help or suggestions would be greatly appreciated.
    Thank You

  2. #2
    Just Joined!
    Join Date
    May 2005
    Posts
    3
    The box I use at work uses: security = Share . If this does not work for you I also used the net join command so that it can be seen by the domain controller.

  3. #3
    Just Joined!
    Join Date
    Feb 2004
    Location
    Indonesia
    Posts
    84
    see my post,

    http://www.linuxforums.org/forum/topic-42867.html

    then you could add share restricted file do :
    #smbadduser userUnix:usersamba (kamto:kamtono -> kamtono as a samba user)
    than add valid user kamtono to your restricted file share + restart smb daemon

    just that !

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •