Find the answer to your Linux question:
Results 1 to 3 of 3
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    need help uninstalling old samba version


    I'm trying to uninstall samba 3.0.10-1.fc3 to install the new version but run into problems when trying to uninstall samba-client and samba-common.

    Here's what I get

    Code:
    # rpm -e samba-client
    error: Failed dependencies:
            samba-client is needed by (installed) authconfig-gtk-4.6.5-3.1.i386
            samba-client is needed by (installed) AutoScan-0.95-1.i386
    and
    Code:
    # rpm -e samba-common-3.0.10-1.fc3
    error: Failed dependencies:
            libsmbclient.so.0 is needed by (installed) gnome-vfs2-smb-2.8.2-8.i386
            libsmbclient.so.0 is needed by (installed) kdebase-3.3.0-8.i386
            libsmbclient.so.0 is needed by (installed) AutoScan-0.95-1.i386
            samba-common is needed by (installed) authconfig-gtk-4.6.5-3.1.i386
            samba-common >= 3.0.8-0.pre1.3 is needed by (installed) gnome-vfs2-smb-2.8.2-8.i386
            samba-common = 0:3.0.10 is needed by (installed) samba-client-3.0.10-1.fc3.i386
    Thanks in advance
    You dont need a pocket protector or thick glasses to be a geek.

  2. #2
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    Code:
    rpm -e samba-client --no-deps
    then install the new one right away to prevent breakage.

  3. #3

    Samba

    Greetings,

    Did you tried to upgrade the Samba package b4 uninstalling it as the new package of Samba will look for more dependency files. So, I wud suggest you to do an upgrade instead on uninstalling it using -iUvh option.

    Regards

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •